summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2015-09-24 10:09:45 -0400
committergraysky2015-09-24 10:09:45 -0400
commitede1d2133a2c62ebccd3891458e705aa55e43db5 (patch)
treed44c102ba5e6e814cfbbaf84defd4648e48eee42
parent7de38cd106dcf5ea3f3ef07ea9a18949811958b2 (diff)
downloadaur-ede1d2133a2c62ebccd3891458e705aa55e43db5.tar.gz
Update to 3.71-4
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
-rw-r--r--flac2all.121
3 files changed, 13 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 122a1cb1af13..0a35176c42f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = flac2all
pkgdesc = Multi-threaded audio converter of FLAC to either Ogg Vorbis or MP3 retaining all tags and metadata.
pkgver = 3.71
- pkgrel = 3
- url = http://code.google.com/p/flac2all
+ pkgrel = 4
+ url = https://github.com/ZivaVatra/flac2all
arch = any
license = GPL2
depends = flac
@@ -11,10 +11,8 @@ pkgbase = flac2all
optdepends = vorbis-tools: for ogg support
optdepends = opus-tools: for opus support
conflicts = flac2all-svn
- source = flac2all_v3.71.py::http://flac2all.witheredfire.com/cgi-bin/download.cgi?download=flac2all_v3.71.py
- source = flac2all.1
- sha256sums = 7b451635f2c680431b227fc07e356f58c2a709d88e2bfe9ff021b675d6b54f26
- sha256sums = a55806a227d5370681dc42d6f86fc7a3f3e7ae7e460bbc1a5f3065721b3f75bb
+ source = https://github.com/graysky2/flac2all/archive/v3.71.tar.gz
+ sha256sums = 2bae1c535dad613f659ea42e8c769f4bb9a89b940edfbeaee60e8561ffcf77e8
pkgname = flac2all
diff --git a/PKGBUILD b/PKGBUILD
index 673e715d3897..c03a3a264f76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgname=flac2all
pkgver=3.71
-pkgrel=3
+pkgrel=4
pkgdesc="Multi-threaded audio converter of FLAC to either Ogg Vorbis or MP3 retaining all tags and metadata."
arch=('any')
-url="http://code.google.com/p/flac2all"
+url="https://github.com/ZivaVatra/flac2all"
license=('GPL2')
conflicts=('flac2all-svn')
depends=('flac' 'python2')
@@ -13,14 +13,13 @@ optdepends=('lame: for mp3 support'
'vorbis-tools: for ogg support'
'opus-tools: for opus support')
-# temp hosting until Ziva finds a permanent host
-#source=(http://$pkgname.googlecode.com/files/"$pkgname"_v$pkgver.py
-source=("flac2all_v$pkgver.py::http://flac2all.witheredfire.com/cgi-bin/download.cgi?download=flac2all_v$pkgver.py"
-$pkgname.1)
-sha256sums=('7b451635f2c680431b227fc07e356f58c2a709d88e2bfe9ff021b675d6b54f26'
- 'a55806a227d5370681dc42d6f86fc7a3f3e7ae7e460bbc1a5f3065721b3f75bb')
+# graysky is temp hosting on his github until Ziva tags his releases
+source=("https://github.com/graysky2/flac2all/archive/v$pkgver.tar.gz")
+sha256sums=('2bae1c535dad613f659ea42e8c769f4bb9a89b940edfbeaee60e8561ffcf77e8')
package() {
- install -Dm755 flac2all_v$pkgver.py "$pkgdir"/usr/bin/$pkgname
- install -Dm644 $pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 stable/$pkgname.py "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 stable/$pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
}
diff --git a/flac2all.1 b/flac2all.1
deleted file mode 100644
index 621b58153129..000000000000
--- a/flac2all.1
+++ /dev/null
@@ -1,21 +0,0 @@
-.\" Text automatically generated by txt2man
-.TH flac2all "1"
-.SH NAME
-\fBFlac2all \fP- is a multi-threaded python script that will convert FLAC files into either Ogg Vorbis, MP3 (with the Lame encoder), or FLAC, complete with the metadata from the original file.
-\fB
-.SH SYNOPSIS
-.nf
-.fam C
- \fBflac2all\fP [\fIconvert\fP \fItype\fP] [\fIinput\fP \fIdir\fP]
- [\fIconvert\fP \fItype\fP] \fImay\fP \fIbe\fP [\fImp3\fP] \fIor\fP [\fIvorbis\fP] \fIor\fP [\fIflac\fP]
-
-.fam T
-.fi
-.fam T
-.fi
-.SH DESCRIPTION
-Flac2All is a multi-threaded script that will \fIconvert\fP your collection of FLAC files into either Ogg Vorbis, MP3 (with the Lame encoder), \fIor\fP FLAC, complete with any tags that the source file had. Utility for people with with large FLAC collections who also want a lossy version for portable media players.
-.SH BUGS
-Not all metadata is transferred to the \fImp3\fP format compared to the \fIvorbis\fP format.
-.SH AUTHOR
-ziva_vatra@mailshack.com