summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Squartini2017-11-18 21:09:42 +0100
committerNicola Squartini2017-11-18 21:09:42 +0100
commit51fd7fa047dfc2639d985f5dad98af0ed7de5e5c (patch)
tree52fd2e254ad9de078ac894c363b1f7a9b87dfbb4
parenta36b04f3842aac3b5997483500cecb6f10107529 (diff)
downloadaur-51fd7fa047dfc2639d985f5dad98af0ed7de5e5c.tar.gz
Update to version 0.3.8
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD13
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7528c1ff786..b610965e4db8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Feb 10 11:30:30 UTC 2017
+# Sat Nov 18 20:08:44 UTC 2017
pkgbase = flaccuraterip
pkgdesc = Verify FLAC files ripped from CD using AccurateRip™
- pkgver = 0.3.7
+ pkgver = 0.3.8
pkgrel = 1
url = http://hackage.haskell.org/package/flaccuraterip
arch = i686
@@ -16,13 +16,14 @@ pkgbase = flaccuraterip
makedepends = haskell-http>=4000.2
makedepends = haskell-http<4000.4
makedepends = haskell-optparse-applicative>=0.10
- makedepends = haskell-optparse-applicative<0.14
- makedepends = haskell-process>=1.4
- makedepends = haskell-process<1.5
- depends = gmp
+ makedepends = haskell-optparse-applicative<0.15
+ makedepends = haskell-process>=1.5
+ makedepends = haskell-process<1.7
+ depends = haskell-http
+ depends = haskell-optparse-applicative
options = strip
- source = http://hackage.haskell.org/packages/archive/flaccuraterip/0.3.7/flaccuraterip-0.3.7.tar.gz
- sha256sums = b0cd908d8fe4cddc01e93cae85748717c41b183be5ce1a620ea6b4c776d4ba8f
+ source = http://hackage.haskell.org/packages/archive/flaccuraterip/0.3.8/flaccuraterip-0.3.8.tar.gz
+ sha256sums = 1aa77d70128cc250584f03adb1f5f579914a9fdd2f96298c9003da6bd72eb347
pkgname = flaccuraterip
diff --git a/PKGBUILD b/PKGBUILD
index 60b79a7c1200..6d6359dac898 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nicola Squartini <tensor5@gmail.com>
_hkgname=flaccuraterip
pkgname=flaccuraterip
-pkgver=0.3.7
+pkgver=0.3.8
pkgrel=1
pkgdesc="Verify FLAC files ripped from CD using AccurateRip™"
url="http://hackage.haskell.org/package/${_hkgname}"
@@ -11,17 +11,18 @@ makedepends=('ghc'
'haskell-binary>=0.5' 'haskell-binary<0.9'
'haskell-deepseq>=1.3' 'haskell-deepseq<1.5'
'haskell-http>=4000.2' 'haskell-http<4000.4'
- 'haskell-optparse-applicative>=0.10' 'haskell-optparse-applicative<0.14'
- 'haskell-process>=1.4' 'haskell-process<1.5'
+ 'haskell-optparse-applicative>=0.10' 'haskell-optparse-applicative<0.15'
+ 'haskell-process>=1.5' 'haskell-process<1.7'
)
-depends=('gmp')
+depends=('haskell-http'
+ 'haskell-optparse-applicative')
options=('strip')
source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
-sha256sums=('b0cd908d8fe4cddc01e93cae85748717c41b183be5ce1a620ea6b4c776d4ba8f')
+sha256sums=('1aa77d70128cc250584f03adb1f5f579914a9fdd2f96298c9003da6bd72eb347')
build() {
cd "${srcdir}/${_hkgname}-${pkgver}"
- runhaskell Setup configure --prefix=/usr --docdir=/usr/share/doc/${pkgname} -O
+ runhaskell Setup configure --prefix=/usr --docdir=/usr/share/doc/${pkgname} -O --enable-executable-dynamic
runhaskell Setup build
}