summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Düll2015-07-04 14:01:55 +0200
committerMichael Düll2015-07-04 14:01:55 +0200
commitc337abf5d684f6c4e0c70da993bc90830d396f76 (patch)
treee6dd943568dec2347f6bb4f569feecaf5792ec3c
downloadaur-c337abf5d684f6c4e0c70da993bc90830d396f76.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
-rw-r--r--help.patch41
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f29cf60c3570
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = flacgain
+ pkgdesc = FLAC Replay Gain script similar to mp3gain and vorbisgain that uses metaflac.
+ pkgver = 0.2
+ pkgrel = 5
+ url = http://projects.robinbowes.com/apply_replaygain/trac
+ arch = any
+ license = GPL
+ depends = perl
+ depends = flac
+ source = http://projects.robinbowes.com/download/apply_replaygain/apply_replaygain-0.2.tar.gz
+ source = help.patch
+ sha512sums = 46dcd81631a14c4b2fe873f01a29e8fa87d43eed7f37f9c663e1f9a99b9c00952873b68023640994ef513ff6841814ec4d9c1291fde7f7c23206d12896fd5fe8
+ sha512sums = 55ac98f4ec1b285a7c2c5ce331abfaf076c6db2b9d5a765ce92cb647f33bd4d9b57b8f3f70fc241ba1619496e4790bf7a9c6c927d45a7b826c08b87ddd83853b
+
+pkgname = flacgain
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5bcf9cb0ce2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Michael Düll <mail@akurei.me> PGP-Key: AAAEE882
+
+pkgname=flacgain
+pkgver=0.2
+pkgrel=5
+pkgdesc="FLAC Replay Gain script similar to mp3gain and vorbisgain that uses metaflac."
+arch=('any')
+url="http://projects.robinbowes.com/apply_replaygain/trac"
+license=('GPL')
+depends=('perl' 'flac')
+source=(http://projects.robinbowes.com/download/apply_replaygain/apply_replaygain-${pkgver}.tar.gz
+ help.patch)
+sha512sums=('46dcd81631a14c4b2fe873f01a29e8fa87d43eed7f37f9c663e1f9a99b9c00952873b68023640994ef513ff6841814ec4d9c1291fde7f7c23206d12896fd5fe8'
+ '55ac98f4ec1b285a7c2c5ce331abfaf076c6db2b9d5a765ce92cb647f33bd4d9b57b8f3f70fc241ba1619496e4790bf7a9c6c927d45a7b826c08b87ddd83853b')
+
+package() {
+ cd "$srcdir"
+ tar xfz apply_replaygain-$pkgver.tar.gz
+ cd "$srcdir/apply_replaygain-$pkgver"
+ patch apply_replaygain.pl ../../help.patch
+ install -D -o root -g root -m 755 apply_replaygain.pl ${pkgdir}/usr/bin/flacgain
+ mkdir -p ${pkgdir}/usr/lib/perl5/vendor_perl/
+ mv lib/Audio ${pkgdir}/usr/lib/perl5/vendor_perl/
+ chown root:root -R ${pkgdir}/usr/lib/perl5/vendor_perl/Audio
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/help.patch b/help.patch
new file mode 100644
index 000000000000..2767e8bb4736
--- /dev/null
+++ b/help.patch
@@ -0,0 +1,41 @@
+--- apply_replaygain.pl 2007-12-31 14:55:39.000000000 +0100
++++ apply_replaygain.pl.new 2011-01-05 18:31:38.112189683 +0100
+@@ -43,7 +43,7 @@ use Getopt::Long;
+ our $metaflaccmd = "metaflac";
+
+ # Depending on your application, you may not require --preserve-modtime
+-our @flacargs = qw ( --preserve-modtime --add-replay-gain );
++our @flacargs = qw ( --add-replay-gain );
+
+ #-------------------- End User-changeable options ---------------------
+
+@@ -66,7 +66,7 @@ GetOptions( \%Options,
+ #$d_info = 0;
+ #$d_debug = 0;
+
+-showusage() unless ( scalar @ARGV <= 1 );
++showusage() if ( scalar @ARGV <= 0 );
+
+ # Use current directory if no dir specified on command-line
+ @ARGV = ('.') unless @ARGV;
+@@ -147,7 +147,19 @@ sub process_dirs {
+ }
+
+ sub showusage {
+- print "Usage goes here\n";
++print "flacgain [options] [directory]
++
++Options:
++ --processall Default behaviour is if all files in the directory
++ have ReplayGain information (specifically, the
++ REPLAY_ALBUM_GAIN tag) then the directory is skipped.
++ This option recalculates ReplayGain information
++ for all directories.
++ --info Output information (directories processed, etc.)
++ --debug Output debugging information
++
++directory is the directory to scan for flac files. If omitted, the
++current directory is processed.\n";
+ exit 1;
+ }
+