summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2017-08-14 10:07:48 +0200
committerValHue2017-08-14 10:07:48 +0200
commit75295c611a3fe3581caf15ed874a4ac416fa29ef (patch)
tree65c19f97701fc5657701fcfa5f4cda6eef28b5f9
parent4abc3ecf07055b4162b887cbb9149404232857aa (diff)
downloadaur-75295c611a3fe3581caf15ed874a4ac416fa29ef.tar.gz
Update to 3.1.1-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28ada3eda7fd..b1e5c5d050f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = flacon
pkgdesc = Extracts individual tracks from one big audio file containing the entire album of music and saves them as separate audio files.
- pkgver = 3.0.0
- pkgrel = 3
+ pkgver = 3.1.1
+ pkgrel = 1
url = https://flacon.github.io/
arch = i686
arch = x86_64
@@ -24,8 +24,8 @@ pkgbase = flacon
optdepends = vorbisgain: For OGG Replay Gain support
provides = flacon
conflicts = flacon-git
- source = https://github.com/flacon/flacon/archive/v3.0.0.tar.gz
- sha256sums = 5349fdc29c6cb173e7d40260e7ea4ba13ae39f4a144c22028fbfa132ceef5bb3
+ source = https://github.com/flacon/flacon/archive/v3.1.1.tar.gz
+ sha256sums = ca5bd24ba61fc06a39e95b4b7fda188af437ad3eff666b55071895bde11bd15a
pkgname = flacon
diff --git a/PKGBUILD b/PKGBUILD
index 834ab848b752..f943dd20d364 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: Artem Sereda <overmind88 at gmail dot com>
pkgname="flacon"
-pkgver=3.0.0
-pkgrel=3
+pkgver=3.1.1
+pkgrel=1
pkgdesc="Extracts individual tracks from one big audio file containing the \
entire album of music and saves them as separate audio files."
arch=('i686' 'x86_64')
@@ -26,14 +26,14 @@ optdepends=('flac: For FLAC support'
conflicts=('flacon-git')
provides=("${pkgname}")
source=("https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('5349fdc29c6cb173e7d40260e7ea4ba13ae39f4a144c22028fbfa132ceef5bb3')
+sha256sums=('ca5bd24ba61fc06a39e95b4b7fda188af437ad3eff666b55071895bde11bd15a')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- mkdir build
-
- cd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ mkdir build
+
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
make
}
@@ -41,8 +41,7 @@ package() {
cd "${srcdir}/${pkgname}-${pkgver}/build"
install -d ${pkgdir}/usr/share/licenses/${pkgname}
install -m 644 ../LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" install
}
-
# vim:set ts=4 sw=2 ft=sh et: