summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-11-25 16:37:31 +0100
committersL1pKn072022-11-25 16:37:31 +0100
commit17660c64607a8b70e3fed5c23abf704bc4945d0f (patch)
tree9229ca8b84ec2c8ff74575d642abd75f736c7c93
parent147bf49c47ee2feb3ae7024952470e5c69679311 (diff)
downloadaur-17660c64607a8b70e3fed5c23abf704bc4945d0f.tar.gz
bump
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 27 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e3a32ceb1c5..c6ab79368ec1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,19 @@
pkgbase = flacon-git
pkgdesc = Extracts individual tracks from one big audio file containing the entire album of music and saves them as separate audio files. (Git Version)
- pkgver = 8.3.0.4.g7f3dad3
+ pkgver = 9.5.1.0.g9b3bef9
pkgrel = 1
url = http://flacon.github.io
arch = x86_64
license = LGPL2.1
+ checkdepends = faac
+ checkdepends = flac
+ checkdepends = lame
+ checkdepends = mac
+ checkdepends = vorbis-tools
+ checkdepends = ttaenc
+ checkdepends = wavpack
+ checkdepends = alacenc-git
+ checkdepends = sox
makedepends = git
makedepends = cmake
makedepends = qt5-tools
@@ -22,6 +31,8 @@ pkgbase = flacon-git
optdepends = ttaenc: For TrueAudio support
optdepends = vorbisgain: For OGG Replay Gain support
optdepends = wavpack: For WavPack support
+ optdepends = alacenc-git: For ALAC Support
+ optdepends = sox: for SOX support
provides = flacon
conflicts = flacon
options = debug
diff --git a/PKGBUILD b/PKGBUILD
index c31d5033cb47..7834180f4f1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=flacon-git
-pkgver=8.3.0.4.g7f3dad3
+pkgver=9.5.1.0.g9b3bef9
pkgrel=1
pkgdesc="Extracts individual tracks from one big audio file containing the entire album of music and saves them as separate audio files. (Git Version)"
arch=('x86_64')
@@ -26,7 +26,19 @@ optdepends=('faac: For AAC support'
'ttaenc: For TrueAudio support'
'vorbisgain: For OGG Replay Gain support'
'wavpack: For WavPack support'
+ 'alacenc-git: For ALAC Support'
+ 'sox: for SOX support'
)
+checkdepends=('faac'
+ 'flac'
+ 'lame'
+ 'mac'
+ 'vorbis-tools'
+ 'ttaenc'
+ 'wavpack'
+ 'alacenc-git'
+ 'sox'
+ )
conflicts=('flacon')
provides=('flacon')
source=('git+https://github.com/flacon/flacon.git')
@@ -53,5 +65,5 @@ check() {
}
package() {
- DESTDIR="${pkgdir}" cmake --build build --target install
+ DESTDIR="${pkgdir}" cmake --install build
}