summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorflaketill2017-06-21 22:21:01 -0600
committerflaketill2017-06-21 22:21:01 -0600
commit2a895ea3f5f1e7e526d88217f6c2090d12d9db5b (patch)
treeaf641a10f983eeb9f78fc0aa7de120b62adf8e8c
parent3512dd5244f1f9b99086af495af9521e8b4d0730 (diff)
downloadaur-2a895ea3f5f1e7e526d88217f6c2090d12d9db5b.tar.gz
A base PKGBUILD to install from git repo
-rw-r--r--PKGBUILD26
1 files changed, 24 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 66dce7869cac..6d4f3a8c5958 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,5 +8,27 @@ pkgver=0.0.1
pkgrel=2
pkgdesc="A simple dotfiles restore for develop on Arch Linux x64"
arch=('x86_64')
-url="https://flaketill@bitbucket.org/flaketill/dotfiles.git"
-license=('GPL') \ No newline at end of file
+#url="https://bitbucket.org/flaketill/dotfiles"
+url="https://github.com/flaketill/dotfiles"
+license=('GPL')
+
+depends=('python2' 'espeak' 'dialog')
+checkdepends=('gdb')
+makedepends=('git' 'terminator' 'namcap')
+optdepends=('gksu: sudo-save support',
+ 'alsa-lib: sound support')
+
+#install=${pkgname}.install
+#source=(git@bitbucket.org:flaketill/dotfiles.git)
+#source=("git+https://flaketill@bitbucket.org/flaketill/dotfiles.git")
+source=("git+https://github.com/flaketill/dotfiles.git")
+#https://github.com/flaketill/flaketill-says
+#source=("https://github.com/flaketill/dotfiles")
+md5sums=('SKIP')
+
+package() {
+ cd ${srcdir}/${_pkgname}
+ #install -Dm755 ${_pkgname}${pkgdir}/usr/bin/${pkgname}
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ #install -Dm644 man/${pkgname}.1 ${pkgdir}/usr/share/man/man1/${pkgname}.1
+} \ No newline at end of file