summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmando Ibarra2016-05-05 13:00:01 -0600
committerArmando Ibarra2016-05-05 13:00:01 -0600
commit1122f58ba014036b552c56a0fab791fde272aa87 (patch)
tree40e723c0778871f7c3c84d0329c39a72864d0e42
parent789fd445190992ecff5e7be64b4fe50d80ac6cc3 (diff)
downloadaur-1122f58ba014036b552c56a0fab791fde272aa87.tar.gz
Fix: cannot create symbolic link pkg/usr/bin
-rw-r--r--PKGBUILD30
1 files changed, 29 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08afdac670a5..ac2a868a5dbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,16 +31,44 @@ source=("${pkgname}.desktop"
md5sums=('b92a253536ce1275a8c91d6ed9d7b2f7'
'ccc2acc3cf18f71c517e42fc2eb4d77b')
+build() {
+
+ #cd "$pkgname-$pkgver"
+ #./configure --prefix=/usr
+ #make
+
+ cd "${srcdir}"
+}
+
+check() {
+
+ #cd "$pkgname-$pkgver"
+ #make -k check
+
+ cd "${srcdir}"
+ #check if exist files base
+
+ if [ -f "${pkgname}"" ]; then
+ if [ -f "${pkgname}.desktop"]; then
+
+ fi
+ else
+ exit 0
+ fi
+}
+
package() {
cd "${srcdir}"
+ install -dm755 "${pkgdir}/usr/bin"
+
cp --preserve=mode -r "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
install -dm755 "${pkgdir}/usr/share/applications"
install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -dm755 "${pkgdir}/usr/bin"
+
} \ No newline at end of file