summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmando Ibarra2016-05-05 10:36:59 -0600
committerArmando Ibarra2016-05-05 10:36:59 -0600
commit9976bbdceecc5612a58025898a5e9a78bb5e3a0a (patch)
tree10ade223b37caf5c57b034ee6ed302fe7f867c87
downloadaur-9976bbdceecc5612a58025898a5e9a78bb5e3a0a.tar.gz
Test new package for aur tested on arch linux x64
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
-rwxr-xr-xflaketill-says138
-rw-r--r--flaketill-says.desktop13
-rw-r--r--flaketill-says.install19
5 files changed, 228 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dcfa3aa824ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = flaketill-says
+ pkgdesc = An app for your console to proyects manager, for example if you write on your console application flaketill says: What do yo do? In the future i'll build an app like jarvis but for moment is a dream
+ pkgver = 0.0.1
+ pkgrel = 2
+ url = https://artpcweb.appspot.com/
+ install = flaketill-says.install
+ arch = x86_64
+ license = GPL
+ checkdepends = gdb
+ makedepends = lx-terminal
+ makedepends = terminator
+ makedepends = namcap
+ depends = python2
+ depends = espeak
+ optdepends = gksu: sudo-save support,
+ optdepends = alsa-lib: sound support
+ source = flaketill-says
+ md5sums = ccc2acc3cf18f71c517e42fc2eb4d77b
+
+pkgname = flaketill-says
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9d725ed4c14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Armando Ibarra <armandoibarra1@gmail.com>
+# Contributor: flaketill <armandoibarra1 at gmail dot com>
+
+pkgname=flaketill-says
+pkgver=0.0.1
+pkgrel=2
+
+pkgdesc="An app for your console to proyects manager, for example if you write on your console application flaketill says: What do yo do? In the future i'll build an app like jarvis but for moment is a dream"
+arch=('x86_64')
+url="https://artpcweb.appspot.com/"
+license=('GPL')
+
+depends=('python2' 'espeak')
+checkdepends=('gdb')
+makedepends=('lx-terminal' 'terminator' 'namcap')
+optdepends=('gksu: sudo-save support',
+ 'alsa-lib: sound support')
+
+#source_x86_64=("https://raw.githubusercontent.com/flaketill/flaketill-says/testing/dist/aur/flaketill-says")
+
+install=${pkgname}.install
+
+#source=("$pkgname-$pkgver.tar.gz"
+# "$pkgname-$pkgver.patch")
+
+source=("$pkgname")
+
+md5sums=('ccc2acc3cf18f71c517e42fc2eb4d77b')
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+ install -dm755 "${pkgdir}/usr/share/applications"
+
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+} \ No newline at end of file
diff --git a/flaketill-says b/flaketill-says
new file mode 100755
index 000000000000..c981479f44e0
--- /dev/null
+++ b/flaketill-says
@@ -0,0 +1,138 @@
+#!/usr/bin/env sh
+# -*- coding: UTF-8 -*-
+# Copyright (C) 2014 Armando Ibarra
+# v0.1 alpha - 2014
+#
+
+#----------------------------------------------------------------------
+# Template file sh or bash
+#
+# Author: Ing. Armando Ibarra - armandoibarra1@gmail.com
+# Email: armandoibarra1@gmail.com
+# Date: 13/06/2014
+# Purpose:
+# Performs the install wps lenguages (like spanish)
+# this shell script try to install depencences
+# on linux OS, invokes some system commands like
+# sudo, pacman, apt-get install, etc
+#
+#----------------------------------------------------------------------
+# NOTES:
+#----------------------------------------------------------------------
+# I prefer LibreOffice but if you want use wps on spanish this bash
+# script can help you
+
+# Test on Archlinux,ubuntu 13.10 and Xubuntu 14.04
+#----------------------------------------------------------------------
+
+###############################################################################
+
+# Licensed under the GNU GPL v3 - http://www.gnu.org/licenses/gpl-3.0.txt
+# - or any later version.
+
+# WPS install languages
+# A bash script installing/building all needed dependencies to
+# build wps languages for just some Linux distributions.
+
+# @author: Ing. Armando Ibarra
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+###############################################################################
+
+#variables
+
+#autor and project data
+AUTHOR='Ing. Armando Ibarra <armandoibarra1@gmail.com>'
+COPYRIGHT='Copyright (c) 2014, armandoibarra1@gmail.com'
+LICENSE='GNU GPL Version 3'
+
+WEB_SITE="https://github.com/erpmtics/erpmtics"
+VERSION_SCRIPT="0.0.1 alpha"
+
+#colors bash script
+GREEN="\033[1;32m"
+RESET="\033[0m"
+WHITE="\033[1;37m"
+BLUE="\033[1;34m"
+RED="\033[1;31m"
+YELLOW="\033[1;33m"
+
+THIS_SCRIPT_PATH=`readlink -f $0`
+THIS_SCRIPT_DIR=`dirname ${THIS_SCRIPT_PATH}`
+TMP_CONF=$HOME"/.erpmtics"
+
+# An error exit function
+
+error()
+{
+
+ echo -e "$RED ${PROGNAME}: ${1:-"Unknown Error"} $RESET" 1>&2
+
+}
+
+error_exit()
+{
+
+ echo -e "$RED ${PROGNAME}: ${1:-"Unknown Error"} $RESET" 1>&2
+ exit 1
+}
+
+show_msn_w()
+{
+
+ echo -e "$WHITE $1 $RESET"
+}
+
+show_msn_warn()
+{
+
+ echo -e "$RED $1 $RESET"
+}
+
+report_bug()
+{
+
+ show_msn_warn "###############_::: Error detected ::: ##############"
+ show_msn_w "Please file a bug report at $BLUE ${WEB_SITE} $RESET"
+ show_msn_w "Project: $BLUE erpmtics $RESET"
+ show_msn_w "Scripts: $BLUE linux/scripts/packages/wps_es.sh $RESET"
+ show_msn_w "Component: $BLUE Packages $RESET"
+ show_msn_w "Label: $BLUE erpmtics $RESET"
+ show_msn_w "Version: $BLUE $VERSION_SCRIPT $RESET"
+ show_msn_w " "
+ echo -e ""$GREEN"Please detail your operating system type, version and any other relevant details" ""$RESET""
+}
+
+show_msn_w "$GREEN installation completed $RESET"
+
+#i don't use cat beacuse the script show with colors on shell
+show_msn_w "#######################$RED IMPORTANT $RESET #######################"
+show_msn_w "##### If are install flaketill-says, please go to home:"
+show_msn_w "##### "
+show_msn_w "##### On your terminal "
+show_msn_w "##### 1. [$USER@$HOSTNAME build]$ cd $HOME "
+show_msn_w "##### 2. [$USER@$HOSTNAME build]$ ls | grep \"es.zip\" "
+show_msn_w "##### "
+show_msn_w "##### if exist file called: es.zip "
+show_msn_w "##### 1. Open flaketill-says "
+show_msn_w "##### [$USER@$HOSTNAME build]$ wps "
+show_msn_w "##### "
+show_msn_w "##### Go to change language and then click on Install new language "
+show_msn_w "##### and finally (Restart) "
+show_msn_w "##### "
+show_msn_w "#######################$RED IMPORTANT $RESET #######################"
+
+
+exit 0
diff --git a/flaketill-says.desktop b/flaketill-says.desktop
new file mode 100644
index 000000000000..4e871fedde5d
--- /dev/null
+++ b/flaketill-says.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=flaketill-says
+GenericName=Management proyects on console
+Comment=A management proyect for your console
+Exec=flaketill-says %F
+Terminal=true
+MimeType=text/plain;
+Icon=flaketill-says
+Categories=Development;
+StartupNotify=true
+StartupWMClass=flaketill-says \ No newline at end of file
diff --git a/flaketill-says.install b/flaketill-says.install
new file mode 100644
index 000000000000..c4a9fb78671f
--- /dev/null
+++ b/flaketill-says.install
@@ -0,0 +1,19 @@
+post_install() {
+ # Update icon cache.
+ gtk-update-icon-cache -f '/usr/share/icons/hicolor' > /dev/null 2>&1
+
+ # Note admin after install/update on how to change th update_check setting.
+ cat << _EOF
+
+ ==> flaketill-says install/upgrade note:
+ ------------------------------------------------------------------------------
+ To config the app for updates,
+ add the following setting to your User Preferences file:
+ "updates": true
+
+_EOF
+}
+
+post_upgrade() {
+ post_install
+} \ No newline at end of file