summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaizhao Zhang2018-05-12 14:47:19 +0800
committerKaizhao Zhang2018-05-12 14:49:23 +0800
commitdea8478b1f2ce3d8fb6c0dad7a34e80a86ee1f78 (patch)
treeb788abcc57d1652382b1ab0cfb9926ad6f9d5dc6
downloadaur-dea8478b1f2ce3d8fb6c0dad7a34e80a86ee1f78.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD23
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f94dcdb76501
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = flamegraph
+ pkgdesc = Flame Graphs visualize profiled code
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.brendangregg.com/flamegraphs.html
+ arch = i686
+ arch = x86_64
+ license = CDDL
+ depends = perl
+ conflicts = flamegraph
+ conflicts = flamegraph-git
+ source = https://github.com/brendangregg/FlameGraph/archive/v1.0.tar.gz
+ sha256sums = c5ba824228a4f7781336477015cb3b2d8178ffd86bccd5f51864ed52a5ad6675
+
+pkgname = flamegraph
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..924dfb95c209
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f1fb753ae4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
+
+pkgname=flamegraph
+pkgver=1.0
+pkgrel=1
+pkgdesc="Flame Graphs visualize profiled code"
+arch=('i686' 'x86_64')
+url="http://www.brendangregg.com/flamegraphs.html"
+license=('CDDL')
+depends=('perl')
+conflicts=('flamegraph' 'flamegraph-git')
+
+source=("https://github.com/brendangregg/FlameGraph/archive/v${pkgver}.tar.gz")
+sha256sums=('c5ba824228a4f7781336477015cb3b2d8178ffd86bccd5f51864ed52a5ad6675')
+
+package() {
+ _srcname=FlameGraph
+ cd "${srcdir}/${_srcname}-${pkgver}"
+
+ install -Dm755 flamegraph.pl "${pkgdir}/usr/bin/flamegraph.pl"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 docs/cddl1.txt "${pkgdir}/usr/share/licenses/${pkgname}/cddl1.txt"
+}