summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfuan_k2022-06-04 16:46:29 +0200
committerfuan_k2022-06-04 16:46:29 +0200
commit0f48b9dcc902443e0f1a31072d5cf8d9c3001271 (patch)
tree6fe61e3dd9700e40310328a28d9fa0fe2ff2fc3c
parentb583a4115f2a723b93265e8acdaefc5768ffa734 (diff)
downloadaur-0f48b9dcc902443e0f1a31072d5cf8d9c3001271.tar.gz
Fix build scripts
Upstream now use CMake to build the project.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD27
2 files changed, 22 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac24f1ab8c13..6e0c43843286 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = flamerobin-git
pkgdesc = A tool to handle Firebird database management
- pkgver = 0.9.3.1
+ pkgver = 0.9.3.11.r7.gde8f182d
pkgrel = 1
url = http://www.flamerobin.org/
arch = i686
arch = x86_64
- license = expat
+ license = MIT
makedepends = git
- depends = wxgtk
+ makedepends = cmake
+ depends = wxgtk3
depends = libfbclient
depends = boost
provides = flamerobin
@@ -16,4 +17,3 @@ pkgbase = flamerobin-git
md5sums = SKIP
pkgname = flamerobin-git
-
diff --git a/PKGBUILD b/PKGBUILD
index dab9721220cd..10727fdb6cba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
# Contributor: Tetsumaki <http://goo.gl/YMBdA>
pkgname=flamerobin-git
-pkgver=0.9.3.1
+pkgver=0.9.3.11.r7.gde8f182d
pkgrel=1
pkgdesc='A tool to handle Firebird database management'
arch=('i686' 'x86_64')
url="http://www.flamerobin.org/"
-license=('expat')
-depends=('wxgtk' 'libfbclient' 'boost')
-makedepends=('git')
+license=('MIT')
+depends=('wxgtk3' 'libfbclient' 'boost')
+makedepends=('git' 'cmake')
provides=('flamerobin')
conflicts=('flamerobin')
source=("$pkgname"::'git+https://github.com/mariuz/flamerobin.git')
@@ -24,13 +24,22 @@ pkgver() {
build() {
cd "$srcdir/$pkgname"
-
- ./configure --prefix=/usr --with-wx-config=/usr/bin/wx-config
-
- make
+
+ # Dirty hack to work around the fact that the build scripts invoke
+ # wx-config which may not exist anymore since wxgtk3
+ OLDPATH="$PATH"
+ export PATH="$(pwd):$PATH"
+ ln -s /usr/bin/wx-config-gtk3 ./wx-config
+
+ ./configure --prefix=/usr --with-wx-config=/usr/bin/wx-config-gtk3
+ cmake -B build -S "./" -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX='/usr' -Wno-dev
+ cmake --build build
+
+ rm ./wx-config
+ export PATH="$OLDPATH"
}
package() {
cd "$srcdir/$pkgname"
- make DESTDIR="${pkgdir}" install
+ DESTDIR="$pkgdir" cmake --install build
}