summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author33kk2020-06-14 00:27:06 +0300
committer33kk2020-06-14 00:27:06 +0300
commit70686f9c5b6c025046caae1ac0febc524de2d176 (patch)
tree632aa7e4907a81888fc483df074485e331517d39
downloadaur-70686f9c5b6c025046caae1ac0febc524de2d176.tar.gz
Create package
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84a41eb3d6a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = flameshot-33kk-git
+ pkgdesc = Powerful yet simple to use screenshot software (with custom uploader and increased blur radius)
+ pkgver = r559.85e82db
+ pkgrel = 1
+ url = https://github.com/33kk/flameshot
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = qt5-tools
+ makedepends = git
+ depends = qt5-base
+ depends = hicolor-icon-theme
+ depends = qt5-svg
+ provides = flameshot-git
+ conflicts = flameshot
+ source = git+https://github.com/33kk/flameshot.git
+ sha256sums = SKIP
+
+pkgname = flameshot-33kk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..185292aec3ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer : 33KK
+
+pkgname=flameshot-33kk-git
+_pkgname=flameshot
+pkgver=r559.85e82db
+pkgrel=1
+pkgdesc="Powerful yet simple to use screenshot software (with custom uploader and increased blur radius)"
+arch=('i686' 'x86_64')
+url="https://github.com/33kk/flameshot"
+license=('GPL')
+depends=(qt5-base hicolor-icon-theme qt5-svg)
+makedepends=(qt5-tools git)
+provides=(flameshot-git)
+conflicts=(flameshot)
+source=("git+https://github.com/33kk/flameshot.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ # Get the version number.
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ qmake CONFIG+=packaging
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make INSTALL_ROOT="${pkgdir}" install
+}