summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFeresey2020-09-04 21:46:19 +0300
committerFeresey2020-09-04 21:47:22 +0300
commit1669ac1cae33577823c2a14b7eed481666b97053 (patch)
tree14e5a52bd93bb406f24b19b2425fe091ef428095
parent5d57a3c4b754f6da1037a7c9744675c44c09ba3e (diff)
downloadaur-1669ac1cae33577823c2a14b7eed481666b97053.tar.gz
Update repo url && change build tools
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a38804ccbb3c..3f56ed6261ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = flameshot-git
pkgdesc = Powerful yet simple to use screenshot software
- pkgver = r549.91ba28c
- pkgrel = 3
- url = https://github.com/lupoDharkael/flameshot
+ pkgver = r562.37fee84
+ pkgrel = 1
+ url = https://github.com/flameshot-org/flameshot
arch = i686
arch = x86_64
license = GPL
makedepends = qt5-tools
makedepends = git
+ makedepends = cmake
depends = qt5-base
depends = hicolor-icon-theme
depends = qt5-svg
provides = flameshot-git
conflicts = flameshot
- source = git+https://github.com/lupoDharkael/flameshot.git
- sha256sums = SKIP
+ source = git+https://github.com/flameshot-org/flameshot.git
+ md5sums = SKIP
pkgname = flameshot-git
diff --git a/PKGBUILD b/PKGBUILD
index 9f0635e9ecee..462ec9759ffe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,18 @@
pkgname=flameshot-git
_pkgname=flameshot
-pkgver=r549.91ba28c
-pkgrel=3
+pkgver=r562.37fee84
+pkgrel=1
pkgdesc="Powerful yet simple to use screenshot software"
arch=('i686' 'x86_64')
-url="https://github.com/lupoDharkael/flameshot"
+url="https://github.com/flameshot-org/flameshot"
license=('GPL')
depends=(qt5-base hicolor-icon-theme qt5-svg)
-makedepends=(qt5-tools git)
+makedepends=(qt5-tools git cmake)
provides=(flameshot-git)
conflicts=(flameshot)
-source=("git+https://github.com/lupoDharkael/flameshot.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/flameshot-org/flameshot.git")
+md5sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -26,11 +26,11 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- qmake CONFIG+=packaging
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
cd "${srcdir}/${_pkgname}"
- make INSTALL_ROOT="${pkgdir}" install
+ make DESTDIR="${pkgdir}" install
}