summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMehrad Mahmoudian2023-08-09 16:02:16 +0300
committerMehrad Mahmoudian2023-08-09 16:02:16 +0300
commit6056eb736a4d2c8cf4c69550defe525f330e8d4d (patch)
tree75e86521b496d84d5ec62514b5c3177fdb8c801c
parentb89f4c399c5711194584351331ce978b6aefbae5 (diff)
downloadaur-6056eb736a4d2c8cf4c69550defe525f330e8d4d.tar.gz
split makefiles into smaller procedures for controllability
-rwxr-xr-xMakefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 24d305d16127..33a8c473db48 100755
--- a/Makefile
+++ b/Makefile
@@ -40,6 +40,7 @@ all help:
$(info --------------------------------------------------------------------------------)
$(info Available arguments:)
$(info - "make test" to test the PKGBUILD file)
+ $(info - "make build" to build the PKGBUILD file just to see if it compiled fine)
$(info - "make deps" to check if dependencies are installed)
$(info - "make clean" to clean the left-over files)
$(info - "make patch" to create a patch to be submitted as contribution)
@@ -49,7 +50,7 @@ all help:
$(info --------------------------------------------------------------------------------)
@:
-deps:
+deps:
# checking if the dependencies are me# checking if the dependencies are mett
$(foreach bin,$(REQUIRED_BINS),\
$(if $(shell command -v $(bin) 2> /dev/null),$(info $(COLOR_SUCCESS)[Ok]$(COLOR_RESET) Found `$(bin)`),$(error ${LINEBREAK}[Error] Missing Dependency. Please install `$(bin)`)))
@@ -61,9 +62,11 @@ clean:
find ./ -maxdepth 1 -name $${F} -exec rm --interactive '{}' \; ; \
done
-test: clean
+build: clean
namcap -i PKGBUILD
makepkg
+
+test: build
sudo pacman -U flameshot-git-r*.zst
patch: