summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMehrad Mahmoudian2023-11-10 16:13:48 +0200
committerMehrad Mahmoudian2023-11-10 16:15:09 +0200
commit84c6eba05493e6e5ed31d445e13dfc387d29c0b6 (patch)
tree0846dcbdc52dc1c3569436d4392ef346a1af2a36
parent1495aa7794699ea0f527debe3f0af19ffc57b029 (diff)
downloadaur-84c6eba05493e6e5ed31d445e13dfc387d29c0b6.tar.gz
[fix] dependencies are corrected as per suggestion of xiota
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 9 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f30a2959e158..c92ab1464d41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = flameshot-git
pkgdesc = Powerful yet simple to use screenshot software
- pkgver = r1629.0fe55916
+ pkgver = r1938.fa29bcb4
pkgrel = 1
url = https://github.com/flameshot-org/flameshot
arch = i686
@@ -12,10 +12,14 @@ pkgbase = flameshot-git
depends = qt5-base
depends = hicolor-icon-theme
depends = qt5-svg
- provides = flameshot-git
+ depends = kguiaddons5
+ optdepends = xdg-desktop-portal: To make Sway, Hyprland, and wlroots work
+ optdepends = xdg-desktop-portal-wlr: To make Sway, Hyprland, and wlroots work
+ optdepends = grim: To make Sway, Hyprland, and wlroots work
+ optdepends = xdg-desktop-portal-kde: For KDE Plasma
+ provides = flameshot
conflicts = flameshot
source = git+https://github.com/flameshot-org/flameshot.git
md5sums = SKIP
pkgname = flameshot-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 6c01c3be4bae..30b0b97ed818 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -57,14 +57,13 @@ pkgdesc="Powerful yet simple to use screenshot software"
arch=('i686' 'x86_64')
url="https://github.com/flameshot-org/flameshot"
license=('GPL')
-depends=(qt5-base hicolor-icon-theme qt5-svg)
+depends=(qt5-base hicolor-icon-theme qt5-svg kguiaddons5)
makedepends=(qt5-tools git cmake)
optdepends=('xdg-desktop-portal: To make Sway, Hyprland, and wlroots work'
'xdg-desktop-portal-wlr: To make Sway, Hyprland, and wlroots work'
'grim: To make Sway, Hyprland, and wlroots work'
- 'kguiaddons5: For KDE Plasma'
'xdg-desktop-portal-kde: For KDE Plasma')
-provides=(flameshot-git)
+provides=(flameshot)
conflicts=(flameshot)
source=("git+https://github.com/flameshot-org/flameshot.git")
md5sums=('SKIP')
@@ -79,18 +78,6 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- # # get the details of the version numbers
- # NORMAL_VERSION="$(grep -oP 'FLAMESHOT_VERSION\s\d+\.\d+\.\d+' CMakeLists.txt | cut -d ' ' -f2)"
- # ROLLING_VERSION="r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
- #
- # # skip the special characters in the versions
- # NORMAL_VERSION_PATTERN="$(echo ${NORMAL_VERSION} | sed 's/\./\\\./g')"
- # ROLLING_VERSION_PATTERN="$(echo ${ROLLING_VERSION} | sed 's/\./\\\./g')"
- #
- # # Replace the version number in the cmake with the combination of versions above
- # sed "s/${NORMAL_VERSION_PATTERN}/${NORMAL_VERSION_PATTERN}_${ROLLING_VERSION_PATTERN}/" CMakeLists.txt
-
-
cmake -S ./ \
-DCMAKE_INSTALL_PREFIX=/usr \
-DUSE_WAYLAND_CLIPBOARD=1 \