summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorj1simon2017-07-08 18:07:33 +0200
committerj1simon2017-07-08 18:07:33 +0200
commitbd32a38ff2c41a37eae2fc1248e536e97644e110 (patch)
treeb5204c2abdf06f7803c59dcfc625d930a8425dde
downloadaur-bd32a38ff2c41a37eae2fc1248e536e97644e110.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2deab590df3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = flameshot-git
+ pkgdesc = Powerful yet simple to use screenshot software
+ pkgver = r119.a609e40
+ pkgrel = 1
+ url = https://github.com/lupoDharkael/flameshot
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = make
+ depends = qt5-base
+ provides = flameshot-git
+ conflicts = flameshot
+ source = git+https://github.com/lupoDharkael/flameshot.git
+ sha256sums = SKIP
+
+pkgname = flameshot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2c023bc45f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: j1simon <stemp@ono.com>
+
+_pkgname=flameshot
+pkgname=flameshot-git
+pkgver=r119.a609e40
+pkgrel=1
+pkgdesc="Powerful yet simple to use screenshot software"
+arch=('i686' 'x86_64')
+url="https://github.com/lupoDharkael/flameshot"
+license=('GPL')
+depends=('qt5-base')
+makedepends=('make')
+provides=('flameshot-git')
+conflicts=('flameshot')
+source=("git+https://github.com/lupoDharkael/flameshot.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ # Get the version number.
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ qmake CONFIG+=packaging BASEDIR="${pkgdir}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make install
+}