summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMehrad Mahmoudian2021-09-02 17:34:34 +0300
committerMehrad Mahmoudian2021-09-02 17:34:34 +0300
commitd72eb6df0d96b46588328d991ae5718a08cf62f1 (patch)
treed6f8f250f88ecd4524131d0d72eb6a241fc14d10
parent11486bd3105d4759919509e282cf4b7f54173368 (diff)
downloadaur-d72eb6df0d96b46588328d991ae5718a08cf62f1.tar.gz
[add] the contributions guide and instructions to assist newcomers
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a71e6aaae2a9..16f9f2622a7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,6 +4,47 @@
# Contributor : Feresey <p.milko1999@yandex.ru>
# Contributor : j1simon <stemp@ono.com>
# Contributor : Feresey <p.milko1999@yandex.ru>
+#
+# Contribution Instructions:
+# 0. Use this as the guide:
+# https://wiki.archlinux.org/title/PKGBUILD
+#
+# 1. clone the git:
+# ```sh
+# git clone https://aur.archlinux.org/flameshot-git.git
+# ```
+#
+# 2. Apply the changes you think are necessary to the following:
+# pkgrel=
+# depends=
+# makedepends=
+# optdepends=
+# build()
+#
+# 3. In terminal, naviagate to the folder you have the PKGBUILD in
+#
+# 4. Test the modified PKGBUILD file with all of the following commands
+# ```sh
+# # read this for more info about namcap: https://wiki.archlinux.org/title/Namcap
+# namcap -i PKGBUILD
+#
+# # read this for more info about makepkg: https://wiki.archlinux.org/title/Makepkg
+# makepkg
+#
+# pacman -U flameshot-git-r*.zst
+# ```
+#
+# 5. Fix any possible errors
+#
+# 6. create a patch with your modifications:
+# ```sh
+# git diff --oneline --graph > my.patch
+# ```
+#
+# 7. copy the content of the my.patch file and post it in the discussion of
+# the AUR: https://aur.archlinux.org/packages/flameshot-git/
+
+
pkgname=flameshot-git
_pkgname=flameshot