summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMehrad Mahmoudian2022-01-30 17:09:52 +0200
committerMehrad Mahmoudian2022-01-30 17:09:52 +0200
commitd84205033b1f27c112a0b9cbc952a2c70234b300 (patch)
tree4bcf5377d821cd0c7f91ad572a0707500326f12e
parente3350d07dc92e24c2a1142abbcf2e340599cf6fb (diff)
downloadaur-d84205033b1f27c112a0b9cbc952a2c70234b300.tar.gz
[add] kguiaddons was added to fix the wayland clipboard issue #2276
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c71ef3774bf..1ab1d6df067b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -58,7 +58,7 @@ arch=('i686' 'x86_64')
url="https://github.com/flameshot-org/flameshot"
license=('GPL')
depends=(qt5-base hicolor-icon-theme qt5-svg)
-makedepends=(qt5-tools git cmake)
+makedepends=(qt5-tools git cmake kguiaddons)
optdepends=('xdg-desktop-portal: To make Sway and wlroots work'
'xdg-desktop-portal-wlr: To make Sway and wlroots work'
'grim: To make Sway and wlroots work')
@@ -87,9 +87,10 @@ build() {
# Replace the version number in the cmake with the combination of versions above
sed "s/${NORMAL_VERSION_PATTERN}/${NORMAL_VERSION_PATTERN}_${ROLLING_VERSION_PATTERN}/" CMakeLists.txt
+ cmake -S ./ \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_WAYLAND_CLIPBOARD=1
-
- cmake -DCMAKE_INSTALL_PREFIX=/usr
make -j$(nproc --ignore 1)
}