summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMehrad Mahmoudian2022-01-30 17:10:15 +0200
committerMehrad Mahmoudian2022-01-30 17:10:15 +0200
commited17e2ccd0a67c22f0998e581ab3a4c592386b92 (patch)
tree4c928f4be629ee4960a848cc38b5e4314208c755
parentd84205033b1f27c112a0b9cbc952a2c70234b300 (diff)
downloadaur-ed17e2ccd0a67c22f0998e581ab3a4c592386b92.tar.gz
commented out the unnecessary version changing lines
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ab1d6df067b..36c9ff068632 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -77,16 +77,18 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- # get the details of the version numbers
- NORMAL_VERSION="$(grep -oP 'FLAMESHOT_VERSION\s\d+\.\d+\.\d+' CMakeLists.txt | cut -d ' ' -f2)"
- ROLLING_VERSION="r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ # # get the details of the version numbers
+ # NORMAL_VERSION="$(grep -oP 'FLAMESHOT_VERSION\s\d+\.\d+\.\d+' CMakeLists.txt | cut -d ' ' -f2)"
+ # ROLLING_VERSION="r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ #
+ # # skip the special characters in the versions
+ # NORMAL_VERSION_PATTERN="$(echo ${NORMAL_VERSION} | sed 's/\./\\\./g')"
+ # ROLLING_VERSION_PATTERN="$(echo ${ROLLING_VERSION} | sed 's/\./\\\./g')"
+ #
+ # # Replace the version number in the cmake with the combination of versions above
+ # sed "s/${NORMAL_VERSION_PATTERN}/${NORMAL_VERSION_PATTERN}_${ROLLING_VERSION_PATTERN}/" CMakeLists.txt
- # skip the special characters in the versions
- NORMAL_VERSION_PATTERN="$(echo ${NORMAL_VERSION} | sed 's/\./\\\./g')"
- ROLLING_VERSION_PATTERN="$(echo ${ROLLING_VERSION} | sed 's/\./\\\./g')"
- # Replace the version number in the cmake with the combination of versions above
- sed "s/${NORMAL_VERSION_PATTERN}/${NORMAL_VERSION_PATTERN}_${ROLLING_VERSION_PATTERN}/" CMakeLists.txt
cmake -S ./ \
-DCMAKE_INSTALL_PREFIX=/usr \
-DUSE_WAYLAND_CLIPBOARD=1