summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Meusel2017-08-12 22:47:17 +0200
committerTim Meusel2017-08-12 22:47:17 +0200
commit6fde3d0dc298a0fde1fc9aa793a6f11370bc966a (patch)
tree39397c4f932f6aec6b3b6d73caec322e2a37af37
parent8d7a3e5bb454dcb7f42579bc0ede033d9b085c4f (diff)
downloadaur-6fde3d0dc298a0fde1fc9aa793a6f11370bc966a.tar.gz
release 0.8.0
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD60
-rw-r--r--flannel.service2
3 files changed, 62 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2c4c61b977f..c272eed07dc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,25 @@
-# Generated by mksrcinfo v8
-# Tue Dec 27 12:24:04 UTC 2016
pkgbase = flannel
pkgdesc = Etcd backed network fabric for containers
- pkgver = 0.6.2
+ pkgver = 0.8.0
pkgrel = 1
url = https://github.com/coreos/flannel
- arch = x86_64
- arch = i686
+ arch = any
license = APACHE
makedepends = go
+ makedepends = git
depends = glibc
- source = https://github.com/coreos/flannel/archive/v0.6.2.tar.gz
source = flannel.service
- sha256sums = 40c315ee78e50b97d2e48e5c32e2d07690b7361fe1ca09efe16d3edda4bc7e33
- sha256sums = 3ec927a5a545293541e800057c3c0b85fcd5161071526a8fc9666caa0801c80f
+ source = git+https://github.com/coreos/flannel#commit=6bbf8bf4923f7185465f46ca09d83667938c4993
+ source = go-pkg::git+https://github.com/coreos/pkg#commit=3ac0863d7acf3bc44daf49afef8919af12f704ef
+ source = git+https://github.com/golang/glog#commit=23def4e6c14b4da8ac2ed8007337bc5eb5007998
+ source = git+https://github.com/joho/godotenv#commit=9d9ddadf44b4c17c42bafdc530ddeee1927c067d
+ source = git+https://github.com/coreos/go-systemd#commit=d2196463941895ee908e13531a23a39feb9e1243
+ sha512sums = 78d44de0f262606c70b328e5d3f7b8fa1abdf234b51c8ace48b812d8c5b00fd169cfe578f0ce187040720baddc8e281e4bfb5146a38012fe83f8c4478a4977b6
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
pkgname = flannel
diff --git a/PKGBUILD b/PKGBUILD
index 4e545ad407fd..51d317ce6024 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,62 @@
-#Maintainer: Iwan Timmer <irtimmer@gmail.com>
+# Maintainer: Tim Meusel <tim@bastelfreak.de>
+# Contributor: Iwan Timmer <irtimmer@gmail.com>
+# Maintainer: Christian Rebischke <Chris.Rebischke[at]archlinux[dot]org>
pkgname=flannel
-pkgver=0.6.2
+pkgver=0.8.0
pkgrel=1
pkgdesc="Etcd backed network fabric for containers"
depends=('glibc')
-makedepends=('go')
-arch=('x86_64' 'i686')
-source=("https://github.com/coreos/flannel/archive/v$pkgver.tar.gz"
- "flannel.service")
+makedepends=('go' 'git')
+arch=('any')
+_flannel_commit='6bbf8bf4923f7185465f46ca09d83667938c4993' # v0.8.0
+_pkg_commit='3ac0863d7acf3bc44daf49afef8919af12f704ef' # v3
+_glog_commit='23def4e6c14b4da8ac2ed8007337bc5eb5007998' # HEAD
+_godotenv_commit='9d9ddadf44b4c17c42bafdc530ddeee1927c067d' # HEAD
+_systemd_commit='d2196463941895ee908e13531a23a39feb9e1243' # v15
+source=("flannel.service"
+ "git+https://github.com/coreos/flannel#commit=${_flannel_commit}"
+ "go-pkg::git+https://github.com/coreos/pkg#commit=${_pkg_commit}"
+ "git+https://github.com/golang/glog#commit=${_glog_commit}"
+ "git+https://github.com/joho/godotenv#commit=${_godotenv_commit}"
+ "git+https://github.com/coreos/go-systemd#commit=${_systemd_commit}")
url="https://github.com/coreos/flannel"
license=("APACHE")
-sha256sums=('40c315ee78e50b97d2e48e5c32e2d07690b7361fe1ca09efe16d3edda4bc7e33'
- '3ec927a5a545293541e800057c3c0b85fcd5161071526a8fc9666caa0801c80f')
+sha512sums=('78d44de0f262606c70b328e5d3f7b8fa1abdf234b51c8ace48b812d8c5b00fd169cfe578f0ce187040720baddc8e281e4bfb5146a38012fe83f8c4478a4977b6'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+
+
+prepare() {
+ export GOPATH="${srcdir}"
+ export PATH="$PATH:$GOPATH/bin"
+ mkdir -p "src/github.com/coreos"
+ mkdir -p "src/github.com/golang"
+ mkdir -p "src/github.com/joho"
+
+ mv ${pkgname} src/github.com/coreos/
+ mv go-pkg src/github.com/coreos/pkg
+ mv go-systemd src/github.com/coreos/
+ mv glog src/github.com/golang/
+ mv godotenv src/github.com/joho/
+
+ cd "src/github.com/coreos/${pkgname}"
+ make test
+}
build() {
- cd $srcdir/flannel-$pkgver
-
- ./build
+ # https://github.com/coreos/flannel/blob/master/Documentation/building.md
+ cd "src/github.com/coreos/${pkgname}"
+ CGO_ENABLED=1 make dist/flanneld
}
package() {
- cd $srcdir/flannel-$pkgver
+ cd "src/github.com/coreos/${pkgname}"
- install -Dm755 bin/flanneld $pkgdir/usr/bin/flannel
+ install -Dm755 dist/flanneld $pkgdir/usr/bin/flanneld
install -Dm644 $srcdir/flannel.service $pkgdir/usr/lib/systemd/system/flannel.service
}
diff --git a/flannel.service b/flannel.service
index d3629a282242..1410255c53dc 100644
--- a/flannel.service
+++ b/flannel.service
@@ -3,7 +3,7 @@ Requires=etcd.service
After=etcd.service
[Service]
-ExecStart=/usr/bin/flannel
+ExecStart=/usr/bin/flanneld
[Install]
WantedBy=multi-user.target