summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Jacobs2015-08-02 15:42:13 -0400
committerJustin Jacobs2015-08-02 15:52:27 -0400
commit1b6527fd8364a72afed87be19923907df49da9c4 (patch)
tree8679b973bac3a91b792e73dca429bb2f6bfbfae0
parent98a9da7c8acc6b13a281d0c24dc89c24d1a1936a (diff)
downloadaur-1b6527fd8364a72afed87be19923907df49da9c4.tar.gz
Don't use temporary build directory
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 7 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..aad091a51a33
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+flare-game-git*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
index 2206685a6440..108fe95c5cc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: dorkster <jajdorkster@gmail.com>
pkgname=flare-game-git
-pkgver=20141113
+pkgver=20150802
pkgrel=1
pkgdesc="Fantasy action RPG using the FLARE engine - Git version"
url="http://www.flarerpg.org/"
@@ -36,12 +36,8 @@ build() {
fi
cd $srcdir/$_repo
- msg "Starting compile..."
- msg "Creating and moving to build directory..."
- mkdir build
- cd build
msg "Running cmake..."
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DDATADIR=share/flare
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DDATADIR=share/flare
msg "Compiling..."
make
}
@@ -49,6 +45,5 @@ build() {
package() {
cd $srcdir/$_repo
msg "Installing..."
- cd build
make install DESTDIR=$pkgdir
}