summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Jacobs2015-08-02 14:27:09 -0400
committerJustin Jacobs2015-08-02 15:52:27 -0400
commit98a9da7c8acc6b13a281d0c24dc89c24d1a1936a (patch)
treec00ca1c0ad894d46e569fe52173d3298363f948d
downloadaur-98a9da7c8acc6b13a281d0c24dc89c24d1a1936a.tar.gz
Migrate to Git-based AUR
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD54
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17b8de7ee18b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = flare-game-git
+ pkgdesc = Fantasy action RPG using the FLARE engine - Git version
+ pkgver = 20150802
+ pkgrel = 1
+ url = http://www.flarerpg.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = CC-BY-SA-3.0
+ makedepends = git>=1.7.10-1
+ makedepends = cmake
+ depends = flare-engine-git
+ conflicts = flare-game
+ replaces = flare-game
+
+pkgname = flare-game-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2206685a6440
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Contributor: dorkster <jajdorkster@gmail.com>
+
+pkgname=flare-game-git
+pkgver=20141113
+pkgrel=1
+pkgdesc="Fantasy action RPG using the FLARE engine - Git version"
+url="http://www.flarerpg.org/"
+license=('GPL3' 'CC-BY-SA-3.0')
+arch=('i686' 'x86_64')
+makedepends=('git>=1.7.10-1' 'cmake')
+depends=('flare-engine-git')
+conflicts=('flare-game')
+replaces=('flare-game')
+
+_gitroot="git://github.com/clintbellanger/"
+_gitname="flare-game"
+_repo="flare-game"
+
+build() {
+ cd $srcdir
+ msg "Connecting to the GIT server..."
+
+ if [[ -d $srcdir/$_repo ]] ; then
+ msg "Updating flare-game"
+ cd $_repo
+ msg "Removing build files..."
+ git clean -dfx
+ msg "Updating..."
+ git pull --no-tags
+ msg "Updating flare"
+ else
+ msg "Cloning..."
+ git clone $_gitroot$_repo --depth 1 --single-branch
+
+ msg "Clone done."
+ fi
+
+ cd $srcdir/$_repo
+ msg "Starting compile..."
+ msg "Creating and moving to build directory..."
+ mkdir build
+ cd build
+ msg "Running cmake..."
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DDATADIR=share/flare
+ msg "Compiling..."
+ make
+}
+
+package() {
+ cd $srcdir/$_repo
+ msg "Installing..."
+ cd build
+ make install DESTDIR=$pkgdir
+}