summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-04-24 16:29:50 -0500
committerLuis Martinez2023-04-24 16:30:22 -0500
commit00d80f66a7a3045409790e72ba85bfc1e74be00c (patch)
treef3dc732609d3d109de179b7689474c42e8943440
parentdbe54334cba2f76dfcd7469dc80e20092ad566d1 (diff)
downloadaur-00d80f66a7a3045409790e72ba85bfc1e74be00c.tar.gz
update to 2.3.1
-rw-r--r--.SRCINFO19
-rw-r--r--CHANGELOG.md17
-rw-r--r--PKGBUILD32
3 files changed, 46 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9da214f9fca2..a6ae9ac4ab24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,30 @@
pkgbase = flashfocus
pkgdesc = Simple Xorg window focus animations for tiling window managers
- pkgver = 2.2.4
- pkgrel = 2
+ pkgver = 2.3.1
+ pkgrel = 1
url = https://www.github.com/fennerm/flashfocus
changelog = CHANGELOG.md
arch = any
license = MIT
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-pytest-runner
+ makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-cffi
- depends = python-xcffib
depends = python-click
- depends = python-xpybutil
+ depends = python-i3ipc
depends = python-marshmallow
+ depends = python-xcffib
+ depends = python-xpybutil
depends = python-yaml
- depends = python-i3ipc
optdepends = i3-wm: compatible window manager
optdepends = sway: compatible window manager
optdepends = bspwm: compatible window manager
optdepends = awesome: compatible window manager
optdepends = xmonad: compatible window manager
optdepends = picom: recommended compositor if using X-based window managers
- source = flashfocus-2.2.4.tar.gz::https://www.github.com/fennerm/flashfocus/archive/v2.2.4.tar.gz
- sha256sums = 346efca50020f7a9b96e1658c8355f25d8b5e5bfb496a2a7048940813f5c8c16
+ source = flashfocus-2.3.1.tar.gz::https://www.github.com/fennerm/flashfocus/archive/v2.3.1.tar.gz
+ sha256sums = c442d5610fa37d5630ae8aff413ee8429bf528fe3428ff185cdb0ba240ac84e3
pkgname = flashfocus
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 5b9ce93bd452..d7ab84574cfe 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,22 @@
# Changelog
+## [2.3.1 - October 21st, 2022]
+- Fixed: #78 Fix error when the current workspace is null (@fennerm)
+- Not user facing: #79 Fixed a bunch of mypy warnings (@fennerm)
+
+## [2.3.0 - September 12th, 2022]
+- Added: #74 pyproject.toml config (@Artturin)
+- Fixed: #77 Rare race condition when detecting the current workspace (@fennerm)
+- Fixed: #78 Traceback when the current workspace is null (@fennerm)
+- Not user facing:
+ - #74 Misc. code cleanup/ linter fixes (@Artturin)
+ - #75 Fix bug in Dockerfile (@Artturin)
+ - #77 Add github action for running tests and fix some flakey tests (@fennerm)
+ - #76 Add CODEOWNERS file (@fennerm)
+
+## [2.2.5 - July 9th, 2022]
+- Fixed: Relax PyYaml dependency (@Artturin)
+
## [2.2.4 - July 30th, 2021]
- Fixed: Remove pytest from setup.py requirements (as it is not really required).
diff --git a/PKGBUILD b/PKGBUILD
index 8e7eebcf40b5..a47592dc91d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,26 @@
# Contributor: Fenner Macrae <fmacrae.dev at gmail dot com>
pkgname=flashfocus
-pkgver=2.2.4
-pkgrel=2
+pkgver=2.3.1
+pkgrel=1
pkgdesc="Simple Xorg window focus animations for tiling window managers"
url="https://www.github.com/fennerm/flashfocus"
license=('MIT')
arch=('any')
depends=(
'python-cffi'
- 'python-xcffib'
'python-click'
- 'python-xpybutil'
+ 'python-i3ipc'
'python-marshmallow'
- 'python-yaml'
- 'python-i3ipc')
-makedepends=('python-setuptools' 'python-pytest-runner')
+ 'python-xcffib'
+ 'python-xpybutil'
+ 'python-yaml')
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-pytest-runner'
+ 'python-setuptools'
+ 'python-wheel')
optdepends=(
'i3-wm: compatible window manager'
'sway: compatible window manager'
@@ -32,11 +37,11 @@ optdepends=(
# 'python-pytest-lazy-fixture')
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('346efca50020f7a9b96e1658c8355f25d8b5e5bfb496a2a7048940813f5c8c16')
+sha256sums=('c442d5610fa37d5630ae8aff413ee8429bf528fe3428ff185cdb0ba240ac84e3')
build() {
cd "$pkgname-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
# check() {
@@ -45,10 +50,9 @@ build() {
# }
package() {
- export PYTHONHASHSEED=0
cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
- install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
- install -Dm644 flashfocus.service -t "$pkgdir/usr/lib/systemd/user/"
+ python -m installer --destdir "$pkgdir" dist/*.whl
+ install -Dvm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ install -Dvm644 flashfocus.service -t "$pkgdir/usr/lib/systemd/user/"
}