summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-08-30 18:30:28 -0500
committerLuis Martinez2021-08-30 18:30:28 -0500
commite4e5783e97061cc1877918098935aea75e4bde34 (patch)
tree3a84b0d7c05882c35a622a82303a2db2246d3535
parent88a553dd1b72e6bbf9acf92cd2d95948f1356297 (diff)
downloadaur-e4e5783e97061cc1877918098935aea75e4bde34.tar.gz
update to 2.2.4
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG.md6
-rw-r--r--PKGBUILD63
3 files changed, 43 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dad1ea27c1be..ba186620c855 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = flashfocus
pkgdesc = Simple Xorg window focus animations for tiling window managers
- pkgver = 2.2.2
- pkgrel = 2
+ pkgver = 2.2.4
+ pkgrel = 1
url = https://www.github.com/fennerm/flashfocus
changelog = CHANGELOG.md
arch = any
@@ -28,7 +28,7 @@ pkgbase = flashfocus
optdepends = awesome: compatible window manager
optdepends = xmonad: compatible window manager
optdepends = picom: recommended compositor if using X-based window managers
- source = flashfocus-2.2.2.tar.gz::https://www.github.com/fennerm/flashfocus/archive/v2.2.2.tar.gz
- sha256sums = 6be9cfb11370212078f6ddc81222220f2b0ae73dff3b1aaf11410536f0ef27c3
+ source = flashfocus-2.2.4.tar.gz::https://www.github.com/fennerm/flashfocus/archive/v2.2.4.tar.gz
+ sha256sums = 346efca50020f7a9b96e1658c8355f25d8b5e5bfb496a2a7048940813f5c8c16
pkgname = flashfocus
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 480866d85bda..5b9ce93bd452 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,11 @@
# Changelog
+## [2.2.4 - July 30th, 2021]
+- Fixed: Remove pytest from setup.py requirements (as it is not really required).
+
+## [2.2.3 - July 12th, 2021]
+- Bump click dependency to v9
+
## [2.2.2 - August 9th, 2020]
- Added: #55 Emit warning when flash-fullscreen: true in sway.
diff --git a/PKGBUILD b/PKGBUILD
index e16c19ca6d02..76940f31db32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,41 +2,44 @@
# Contributor: Fenner Macrae <fmacrae.dev at gmail dot com>
pkgname=flashfocus
-pkgver=2.2.2
-pkgrel=2
+pkgver=2.2.4
+pkgrel=1
pkgdesc="Simple Xorg window focus animations for tiling window managers"
url="https://www.github.com/fennerm/flashfocus"
license=('MIT')
arch=('any')
-depends=('python-cffi>=1.11'
- 'python-cffi<2.0.0'
- 'python-xcffib>=0.6.0'
- 'python-xcffib<1.0.0'
- 'python-click>=6.7'
- 'python-click<9.0.0'
- 'python-xpybutil>=0.0.6'
- 'python-xpybutil<1.0.0'
- 'python-marshmallow>=2.15.0'
- 'python-marshmallow<4.0.0'
- 'python-yaml>=5.1'
- 'python-yaml<6.0.0'
- 'python-i3ipc>=2.1.1'
- 'python-i3ipc<3.0.0')
+depends=(
+ 'python-cffi>=1.11'
+ 'python-cffi<2.0.0'
+ 'python-xcffib>=0.6.0'
+ 'python-xcffib<1.0.0'
+ 'python-click>=6.7'
+ 'python-click<9.0.0'
+ 'python-xpybutil>=0.0.6'
+ 'python-xpybutil<1.0.0'
+ 'python-marshmallow>=2.15.0'
+ 'python-marshmallow<4.0.0'
+ 'python-yaml>=5.1'
+ 'python-yaml<6.0.0'
+ 'python-i3ipc>=2.1.1'
+ 'python-i3ipc<3.0.0')
makedepends=('python-setuptools' 'python-pytest-runner')
-optdepends=('i3-wm: compatible window manager'
- 'sway: compatible window manager'
- 'bspwm: compatible window manager'
- 'awesome: compatible window manager'
- 'xmonad: compatible window manager'
- 'picom: recommended compositor if using X-based window managers')
-# checkdepends=('python-pytest'
-# 'python-pytest-cov'
-# 'python-pytest-factoryboy'
-# 'python-pytest-runner'
-# 'python-pytest-lazy-fixture')
+optdepends=(
+ 'i3-wm: compatible window manager'
+ 'sway: compatible window manager'
+ 'bspwm: compatible window manager'
+ 'awesome: compatible window manager'
+ 'xmonad: compatible window manager'
+ 'picom: recommended compositor if using X-based window managers')
+# checkdepends=(
+# 'python-pytest'
+# 'python-pytest-cov'
+# 'python-pytest-factoryboy'
+# 'python-pytest-runner'
+# 'python-pytest-lazy-fixture')
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('6be9cfb11370212078f6ddc81222220f2b0ae73dff3b1aaf11410536f0ef27c3')
+sha256sums=('346efca50020f7a9b96e1658c8355f25d8b5e5bfb496a2a7048940813f5c8c16')
build() {
cd "$pkgname-$pkgver"
@@ -44,8 +47,8 @@ build() {
}
# check() {
-# cd "$pkgname-$pkgver"
-# pytest -v tests
+# cd "$pkgname-$pkgver"
+# python setup.py pytest
# }
package() {