summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzorfmorf2015-06-11 14:18:35 +0200
committerzorfmorf2015-06-11 14:18:35 +0200
commit31cad3c733637dc575c96fb9e1ffa40729e4b5e9 (patch)
tree539464d39a6f7b3e54d3ef45fc64040d7262da51
downloadaur-31cad3c733637dc575c96fb9e1ffa40729e4b5e9.tar.gz
Initial import
-rw-r--r--.AURINFO21
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD28
-rw-r--r--flashplayer-standalone.install13
-rw-r--r--flashplayer.desktop65
5 files changed, 151 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..a7d44f7f8df0
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,21 @@
+pkgbase = flashplayer-standalone
+ pkgdesc = Macromedia standalone flash player (nonfree)
+ pkgver = 11.2.202.466
+ pkgrel = 1
+ url = http://www.adobe.com/support/flashplayer/downloads.html
+ install = flashplayer-standalone.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = desktop-file-utils
+ depends = lib32-curl
+ depends = lib32-gtk2
+ depends = lib32-libxt
+ depends = lib32-nss
+ source = http://fpdownload.macromedia.com/pub/flashplayer/updaters/11/flashplayer_11_sa.i386.tar.gz
+ source = license.pdf::http://www.adobe.com/products/eulas/pdfs/PlatformClients_PC_WWEULA-MULTI-20110809_1357.pdf
+ source = flashplayer.desktop
+ options = !strip
+
+pkgname = flashplayer-standalone
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf965ee085ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = flashplayer-standalone
+ pkgdesc = Macromedia standalone flash player (nonfree)
+ pkgver = 11.2.202.466
+ pkgrel = 1
+ url = http://www.adobe.com/support/flashplayer/downloads.html
+ install = flashplayer-standalone.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = desktop-file-utils
+ depends = lib32-curl
+ depends = lib32-gtk2
+ depends = lib32-libxt
+ depends = lib32-nss
+ options = !strip
+ source = http://fpdownload.macromedia.com/pub/flashplayer/updaters/11/flashplayer_11_sa.i386.tar.gz
+ source = license.pdf::http://www.adobe.com/products/eulas/pdfs/PlatformClients_PC_WWEULA-MULTI-20110809_1357.pdf
+ source = flashplayer.desktop
+ sha512sums = 70e6b83d2516fbeaa34d9003aa5c8f10d21823f16e8bc7c8ef8b221d2e59c40d1d3dd41acc80b2ee941f7ec81c28ba0c253946c71cabafcebf1adaa95139bc5c
+ sha512sums = a70fd7127f0f9d64f2c872d1e4634d93e24fdea165abfbe20724e68c1b7297df46362cb449b5a78d0eb4a68e43426965359ca93fd4ba4848d2542e5505bcd2fe
+ sha512sums = e4139b265896ebd276b4c7931d5718db7ac8b25e5e86decb2161c94d2b6b410dc7160667cda3a330ece40e64e7809d7afc5ddcc94e09352e84359fa4c7fe3e2d
+
+pkgname = flashplayer-standalone
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dec4b6998be1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: whike <sebastian.tauch@aborium.com>
+
+pkgname=flashplayer-standalone
+pkgver=11.2.202.466
+pkgrel=1
+pkgdesc="Macromedia standalone flash player (nonfree)"
+arch=(i686 x86_64)
+url=http://www.adobe.com/support/flashplayer/downloads.html
+license=(custom)
+# License matrix: http://www.adobe.com/products/eulas/
+depends=(desktop-file-utils lib32-curl lib32-gtk2 lib32-libxt lib32-nss)
+makedepends_x86_64=()
+[[ $CARCH == "i686" ]] && depends=(${depends[@]/lib32-/})
+options=(!strip)
+install=$pkgname.install
+source=(http://fpdownload.macromedia.com/pub/flashplayer/updaters/11/flashplayer_11_sa.i386.tar.gz
+ license.pdf::http://www.adobe.com/products/eulas/pdfs/PlatformClients_PC_WWEULA-MULTI-20110809_1357.pdf
+ flashplayer.desktop)
+sha512sums=('70e6b83d2516fbeaa34d9003aa5c8f10d21823f16e8bc7c8ef8b221d2e59c40d1d3dd41acc80b2ee941f7ec81c28ba0c253946c71cabafcebf1adaa95139bc5c'
+ 'a70fd7127f0f9d64f2c872d1e4634d93e24fdea165abfbe20724e68c1b7297df46362cb449b5a78d0eb4a68e43426965359ca93fd4ba4848d2542e5505bcd2fe'
+ 'e4139b265896ebd276b4c7931d5718db7ac8b25e5e86decb2161c94d2b6b410dc7160667cda3a330ece40e64e7809d7afc5ddcc94e09352e84359fa4c7fe3e2d')
+
+package() {
+ desktop-file-install flashplayer.desktop --dir "$pkgdir"/usr/share/applications/
+ install -Dm644 license.pdf "$pkgdir"/usr/share/licenses/$pkgname/license.pdf
+ install -Dm755 flashplayer "$pkgdir"/usr/bin/flashplayer
+}
+
diff --git a/flashplayer-standalone.install b/flashplayer-standalone.install
new file mode 100644
index 000000000000..49abefe04fc0
--- /dev/null
+++ b/flashplayer-standalone.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-desktop-database -q
+ update-mime-database usr/share/mime &>/dev/null
+ xdg-icon-resource forceupdate
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/flashplayer.desktop b/flashplayer.desktop
new file mode 100644
index 000000000000..eccb3204f513
--- /dev/null
+++ b/flashplayer.desktop
@@ -0,0 +1,65 @@
+[Desktop Entry]
+Type=Application
+Name=Adobe Flash Player
+Name[bg]=Adobe Flash Player
+Name[ca]=Adobe Flash Player
+Name[cs]=Adobe Flash Player
+Name[da]=Adobe Flash Player
+Name[de]=Adobe Flash Player
+Name[es]=Adobe Flash Player
+Name[fi]=Adobe Flash Player
+Name[fr]=Adobe Flash Player
+Name[hu]=Adobe Flash Player
+Name[it]=Adobe Flash Player
+Name[ja]=Adobe Flash Player
+Name[ko]=Adobe Flash Player
+Name[lt]=Adobe Flash Player
+Name[lv]=Adobe Flash Player
+Name[ms]=Adobe Flash Player
+Name[nl]=Adobe Flash Player
+Name[no]=Adobe Flash Player
+Name[pl]=Adobe Flash Player
+Name[pt]=Adobe Flash Player
+Name[pt_BR]=Adobe Flash Player
+Name[ru]=Adobe Flash Player
+Name[sk]=Adobe Flash Player
+Name[sl]=Adobe Flash Player
+Name[sv]=Adobe Flash Player
+Name[tr]=Adobe Flash Player
+Name[uk]=Adobe Flash Player
+Name[vi]=Adobe Flash Player
+Name[zh_CN]=Adobe Flash Player
+Name[zh_TW]=Adobe Flash Player
+Comment=Flash Movie Player
+Comment[bg]=Flash Movie Player
+Comment[ca]=Flash Movie Player
+Comment[da]=Flash Movie Player
+Comment[de]=Flash Movie Player
+Comment[es]=Flash Movie Player
+Comment[fi]=Flash Movie Player
+Comment[fr]=Flash Movie Player
+Comment[hu]=Flash Movie Player
+Comment[it]=Flash Movie Player
+Comment[ja]=Flash Movie Player
+Comment[ko]=Flash Movie Player
+Comment[lt]=Flash Movie Player
+Comment[lv]=Flash Movie Player
+Comment[ms]=Flash Movie Player
+Comment[nl]=Flash Movie Player
+Comment[no]=Flash Movie Player
+Comment[pl]=Flash Movie Player
+Comment[pt]=Flash Movie Player
+Comment[pt_BR]=Flash Movie Player
+Comment[ru]=Flash Movie Player
+Comment[sk]=Flash Movie Player
+Comment[sl]=Flash Movie Player
+Comment[sv]=Flash Movie Player
+Comment[tr]=Flash Movie Player
+Comment[vi]=Flash Movie Player
+Comment[zh_CN]=Flash Movie Player
+Comment[zh_TW]=Flash Movie Player
+Icon=flash
+Exec=flashplayer
+Terminal=false
+Categories=GTK;AudioVideo;Audio;Video;Player;
+MimeType=application/x-shockwave-flash;