summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeSnake042021-10-06 15:14:14 +0200
committerLeSnake042021-10-06 15:25:49 +0200
commit1a3cd47c0bf5551251f22d1881d460d0bea54c5e (patch)
tree801cc623c677d597de9087a5238c91a387d632e3
parent3f9fffc1c48b36119564a6f69a822b731389ba79 (diff)
downloadaur-1a3cd47c0bf5551251f22d1881d460d0bea54c5e.tar.gz
updated to version 10.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD57
-rw-r--r--flashpoint-install-data-files.sh78
-rw-r--r--flashpoint-launcher-bin.install6
4 files changed, 29 insertions, 128 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3c6b5cb0bff..59e6e24a0036 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = flashpoint-launcher-bin
pkgdesc = Launcher for BlueMaxima's Flashpoint with script to install data files
- pkgver = 10.0.0
- pkgrel = 5
+ pkgver = 10.1.1
+ pkgrel = 1
url = https://github.com/FlashpointProject/launcher
- install = flashpoint-launcher-bin.install
arch = x86_64
license = MIT
depends = nss>=3.0
@@ -11,16 +10,11 @@ pkgbase = flashpoint-launcher-bin
depends = gtk3
depends = libxss
depends = wine
- depends = wget
- depends = p7zip
+ depends = flashpoint-data-files-installer
optdepends = flashplayer-standalone: native Flash support
conflicts = flashpoint-bin
conflicts = flashpoint-launcher-git
- source = https://github.com/FlashpointProject/launcher/releases/download/10.0.0/Flashpoint-10.0.0_linux-amd64.deb
- source = flashpoint-install-data-files.sh
- md5sums = 8e998d8d9c77027a67b30ddd3250ffc5
- md5sums = 775dd2b78c17a73edb75040fc86ebfe6
- sha256sums = 19ba5cd803fd05d944df616719eb0e22051d3cc051e8817f4a057d02bf139bfc
- sha256sums = 3591c14565552897c1028ddc513dfbe0a306b96f571d41509886f83a7bd92cc9
+ source = https://github.com/FlashpointProject/launcher/releases/download/10.1.1/Flashpoint-10.1.1_linux-amd64.deb
+ sha512sums = dccc405a8f059887ef5f49b94a94e00e7bd87bf6f12922ffdac301d8339ffe96f482fab53d822cd47c222e5ad4151e8abbc832615525939770229d155c21dd78
pkgname = flashpoint-launcher-bin
diff --git a/PKGBUILD b/PKGBUILD
index 750e9f2f6534..8e6a7c5efa1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,40 @@
# Maintainer: LeSnake <dev.lesnake@posteo.de>
pkgname=flashpoint-launcher-bin
-pkgver=10.0.0
-pkgrel=5
+pkgver=10.1.1
+pkgrel=1
pkgdesc="Launcher for BlueMaxima's Flashpoint with script to install data files"
arch=('x86_64')
url="https://github.com/FlashpointProject/launcher"
license=('MIT')
depends=('nss>=3.0'
- 'php'
- 'gtk3'
- 'libxss'
- 'wine'
- 'wget'
- 'p7zip')
+ 'php'
+ 'gtk3'
+ 'libxss'
+ 'wine'
+ 'flashpoint-data-files-installer')
optdepends=('flashplayer-standalone: native Flash support')
conflicts=('flashpoint-bin' 'flashpoint-launcher-git')
-source=("https://github.com/FlashpointProject/launcher/releases/download/10.0.0/Flashpoint-10.0.0_linux-amd64.deb"
- "flashpoint-install-data-files.sh")
-sha256sums=('19ba5cd803fd05d944df616719eb0e22051d3cc051e8817f4a057d02bf139bfc'
- '3591c14565552897c1028ddc513dfbe0a306b96f571d41509886f83a7bd92cc9')
-md5sums=('8e998d8d9c77027a67b30ddd3250ffc5'
- '775dd2b78c17a73edb75040fc86ebfe6')
-install=flashpoint-launcher-bin.install
+source=("https://github.com/FlashpointProject/launcher/releases/download/${pkgver}/Flashpoint-${pkgver}_linux-amd64.deb")
+sha512sums=('dccc405a8f059887ef5f49b94a94e00e7bd87bf6f12922ffdac301d8339ffe96f482fab53d822cd47c222e5ad4151e8abbc832615525939770229d155c21dd78')
package(){
+ echo Extracting package data ..
+ tar xf data.tar.xz -C ${pkgdir} -v
- # Extract package data
- tar xf data.tar.xz -C ${pkgdir}
+ # Symlink to binary
+ install -d $pkgdir/usr/bin/
+ ln -sfv /opt/Flashpoint/flashpoint-launcher $pkgdir/usr/bin/flashpoint-launcher
- # Symlink to binary
- install -d $pkgdir/usr/bin/
- ln -sf /opt/Flashpoint/flashpoint-launcher $pkgdir/usr/bin/flashpoint-launcher
+ # License
+ install -dv $pkgdir/usr/share/licenses/
+ cp -rv $pkgdir/opt/Flashpoint/licenses/ $pkgdir/usr/share/licenses/Flashpoint
- # License
- install -d $pkgdir/usr/share/licenses/
- mv $pkgdir/opt/Flashpoint/licenses/ $pkgdir/usr/share/licenses/Flashpoint
-
- install -Dm755 $srcdir/flashpoint-install-data-files.sh $pkgdir/usr/bin/flashpoint-install-data-files
-
- # Make config and preferences writable by all
- touch "${pkgdir}/opt/Flashpoint/config.json"
- chmod 666 "${pkgdir}/opt/Flashpoint/config.json"
- touch "${pkgdir}/opt/Flashpoint/preferences.json"
- chmod 666 "${pkgdir}/opt/Flashpoint/preferences.json"
- touch "${pkgdir}/opt/Flashpoint/launcher.log"
- chmod 666 "${pkgdir}/opt/Flashpoint/launcher.log"
+ # Make config and preferences writable by all
+ touch "${pkgdir}/opt/Flashpoint/config.json"
+ chmod 666 "${pkgdir}/opt/Flashpoint/config.json"
+ touch "${pkgdir}/opt/Flashpoint/preferences.json"
+ chmod 666 "${pkgdir}/opt/Flashpoint/preferences.json"
+ touch "${pkgdir}/opt/Flashpoint/launcher.log"
+ chmod 666 "${pkgdir}/opt/Flashpoint/launcher.log"
}
diff --git a/flashpoint-install-data-files.sh b/flashpoint-install-data-files.sh
deleted file mode 100644
index d894fe1190f1..000000000000
--- a/flashpoint-install-data-files.sh
+++ /dev/null
@@ -1,78 +0,0 @@
-#!/bin/bash
-
-FILENAME="./infinity-data-8-2-2b.7z"
-DOWNLOAD_URL="https://bluepload.unstable.life/selif/infinity-data-8-2-2b.7z"
-VALID_SIGNATURE="73ba75598b352244e4a0fda80800fcd1c99f8d98723a83cb495d152f28fcdfed $FILENAME"
-DOWNLOAD_PATH=~/.cache/flashpoint-data
-DOWNLOAD_FULLPATH="$DOWNLOAD_PATH/$FILENAME"
-TARGET_PATH=~/.local/share/flashpoint
-
-downloaddata(){
- echo "Downloading to $DOWNLOAD_FULLPATH"
- wget $DOWNLOAD_URL
-}
-
-getfilesignature(){
- sha256sum $FILENAME
-}
-
-printfilesignature(){
- printf "Actual file signature: \n$(getfilesignature)\nExpected file signature: \n$VALID_SIGNATURE\n"
-}
-
-checkfilesignature(){
- if [ "$(getfilesignature)" = "$VALID_SIGNATURE" ]; then
- echo true
- else
- echo false
- fi
-}
-
-unpackfiles(){
- echo "Unpacking files ..."
- mkdir -p $TARGET_PATH
- 7z x $FILENAME -o$TARGET_PATH -aoa
-}
-
-installwithcheck(){
- mkdir -p $DOWNLOAD_PATH
- cd $DOWNLOAD_PATH
-# Download Archive
- echo "Downloading data ..."
- if [ -f $FILENAME ]; then
- echo "File already found"
- if $(checkfilesignature); then
- echo "valid signature > using cached file"
- else
- echo "Invalid signature > redownloading"
- rm $FILENAME
- downloaddata
- fi
- else
- downloaddata
- fi
- printfilesignature
-# Extract archive
- if $(checkfilesignature) ; then
- echo "Valid signature"
- unpackfiles
- else
- echo "invalid file signature"
- fi
-}
-
-case $1 in
- 'install' )
- installwithcheck
- ;;
- 'force-install' )
- rm -f $FILENAME
- downloaddata
- unpackfiles
- ;;
-# check' )
-# if [ -f $TARGET_PATH/flashpoint.sqlite ]
-# ;;
- * )
- printf "Command line tool to install package files \nCommands:\ninstall : install with integrity check\nforce--install: install without integrity check"
-esac
diff --git a/flashpoint-launcher-bin.install b/flashpoint-launcher-bin.install
deleted file mode 100644
index 5306b65af3d7..000000000000
--- a/flashpoint-launcher-bin.install
+++ /dev/null
@@ -1,6 +0,0 @@
-post_install(){
- echo "make sure to install data files with 'flashpoint-install-data-files install'"
-}
-post_upgrade(){
- echo "make sure to install data files with 'flashpoint-install-data-files install'"
-}