summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeSnake042021-07-24 23:12:32 +0200
committerLeSnake042021-07-24 23:12:32 +0200
commitde165498af850b8ff6807367a522e8d13c353c6f (patch)
treebcd203bdb8d78358006b3ef12f277a364ada6850
downloadaur-de165498af850b8ff6807367a522e8d13c353c6f.tar.gz
base pkgbuild
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD36
-rw-r--r--flashpoint.desktop9
-rw-r--r--icon.pngbin0 -> 11235 bytes
5 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6a85a8d3677
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = flashpoint-launcher-bin
+ pkgdesc = Launcher for BlueMaxima's Flashpoint - Does not include data files! - Launcher software only.
+ pkgver = 10.0.0
+ pkgrel = 1
+ url = https://github.com/FlashpointProject/launcher
+ arch = x86_64
+ license = MIT
+ depends = nss>=3.0
+ depends = php
+ depends = gtk3
+ depends = libxss
+ depends = wine
+ optdepends = flashplayer-standalone: native Flash support
+ conflicts = flashpoint-bin
+ conflicts = flashpoint-launcher-git
+ source = flashpoint-launcher-bin-10.0.0.7z::https://github.com/FlashpointProject/launcher/releases/download/10.0.0/Flashpoint-10.0.0_linux-x64.7z
+ md5sums = cfdebf0c15b03c1a7a6910cc4af7df49
+ sha256sums = fbcb0403c856a5b738f9837c5dbfea8e5cdc6ff2160b5423d1fd7955d98e3c2a
+
+pkgname = flashpoint-launcher-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..521831c7289c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*
+
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!icon.png
+!flashpoint.desktop
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9571429f835
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: LeSnake <dev.lesnake@posteo.de>
+
+pkgname=flashpoint-launcher-bin
+pkgver=10.0.0
+pkgrel=1
+pkgdesc="Launcher for BlueMaxima's Flashpoint - Does not include data files! - Launcher software only."
+arch=('x86_64')
+url="https://github.com/FlashpointProject/launcher"
+license=('MIT')
+depends=('nss>=3.0'
+ 'php'
+ 'gtk3'
+ 'libxss'
+ 'wine')
+optdepends=('flashplayer-standalone: native Flash support')
+conflicts=('flashpoint-bin' 'flashpoint-launcher-git')
+source=($pkgname-$pkgver.7z::"https://github.com/FlashpointProject/launcher/releases/download/10.0.0/Flashpoint-10.0.0_linux-x64.7z")
+sha256sums=('fbcb0403c856a5b738f9837c5dbfea8e5cdc6ff2160b5423d1fd7955d98e3c2a')
+md5sums=('cfdebf0c15b03c1a7a6910cc4af7df49')
+
+package(){
+ # Application
+ rm $srcdir/flashpoint-launcher-bin-$pkgver.7z
+ mkdir -p $pkgdir/opt/flashpoint $pkgdir/usr/share/pixmaps/
+ cp -R $srcdir/* "$pkgdir/opt/flashpoint"
+ #cp $srcdir/$pkgname/icons/icon.png "$pkgdir/usr/share/pixmaps/flashpoint.png"
+
+ # Symlink to binary (WIP)
+ #ln -sf /opt/flashpoint/linux-unpacked/flashpoint-launcher $pkgdir/usr/bin/flashpoint-launcher
+
+ # Desktop Entry (WIP)
+ #install -Dm644 ./flashpoint.desktop "$pkgdir/usr/share/applications/flashpoint.desktop"
+
+ # License
+ install -Dm644 $srcdir/licenses/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/flashpoint.desktop b/flashpoint.desktop
new file mode 100644
index 000000000000..299d703c28ba
--- /dev/null
+++ b/flashpoint.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.1
+Type=Application
+Name=Flashpoint
+Comment=Launcher for BlueMaxima's Flashpoint
+Icon=/usr/share/pixmaps/flashpoint.png
+Exec=/opt/flashpoint/linux-unpacked/flashpoint-launcher
+Actions=
+Categories=Game
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..21aebbb3e0b2
--- /dev/null
+++ b/icon.png
Binary files differ