summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEtaash Mathamsetty2022-10-02 13:03:52 -0400
committerEtaash Mathamsetty2022-10-02 13:03:52 -0400
commiteaf9c589a5d9d57d0e71e687e7cffc30740bfbcf (patch)
tree2c727ac7168b843d51994c8c01915f31eeca6ee1
parent27446b2f049c577fd7fd37aaa92c72138ccc8475 (diff)
downloadaur-eaf9c589a5d9d57d0e71e687e7cffc30740bfbcf.tar.gz
fix some issues with the package
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 026d7a2df162..4148798672dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = flashpoint-launcher-bin
pkgdesc = Launcher for BlueMaxima's Flashpoint
pkgver = 10.1.7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/FlashpointProject/launcher
arch = x86_64
license = MIT
@@ -18,7 +18,7 @@ pkgbase = flashpoint-launcher-bin
optdepends = flashplayer-standalone: native Flash support
conflicts = flashpoint-bin
conflicts = flashpoint-launcher-git
- source = https://github.com/FlashpointProject/launcher/releases/download/10.1.6/Flashpoint-10.1.6_linux-amd64.deb
+ source = https://github.com/FlashpointProject/launcher/releases/download/10.1.7/Flashpoint-10.1.7_linux-amd64.deb
source = https://bluepload.unstable.life/selif/flashpoint-1012-linux-x64.7z
sha512sums = 4e18eec49ff88fcf63177074afc638639cd26b980d6ac54d1b466c31150557a483398a4f9049496d84b3b9e5d511feb6204550f91ce11319b66f67959c53766a
sha512sums = 0b521337d40169ab502f433a107d9b7b7ca73512fb99b27ca547240a251f75e931ca8a6b4450b0dec610b14cb1d1ae1fc9599bb82e757d6cfa79cd76bf5fabe8
diff --git a/PKGBUILD b/PKGBUILD
index 88f9738794e1..31b3b7e31653 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=flashpoint-launcher-bin
pkgver=10.1.7
-pkgrel=1
+pkgrel=2
_dataver=1012
pkgdesc="Launcher for BlueMaxima's Flashpoint"
arch=('x86_64')
@@ -19,7 +19,7 @@ depends=('nss>=3.0'
'wget')
makedepends=('desktop-file-utils'
'git'
- 'p7zip')
+ 'libarchive')
optdepends=('flashplayer-standalone: native Flash support')
conflicts=('flashpoint-bin' 'flashpoint-launcher-git')
source=("flashpoint-data.7z::https://bluepload.unstable.life/selif/flashpoint-${_dataver}-linux-x64.7z"
@@ -44,7 +44,9 @@ package(){
echo "Creating Launcher..."
mkdir -vp "${pkgdir}/usr/bin"
printf \
- "#!/usr/bin/env bash\n\ncd /opt/Flashpoint/\n/opt/Flashpoint/flashpoint-launcher \$@" > "${pkgdir}/usr/bin/flashpoint-launcher"
+ "#!/usr/bin/env bash\n\n
+ cd /opt/Flashpoint/\n
+ /opt/Flashpoint/flashpoint-launcher \$@" > "${pkgdir}/usr/bin/flashpoint-launcher"
chmod -v 777 "${pkgdir}/usr/bin/flashpoint-launcher"
# echo Linking launcher
# mkdir -vp ${pkgdir}/usr/bin