summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeSnake042021-07-24 22:44:52 +0200
committerLeSnake042021-07-24 22:44:52 +0200
commita247d44aee684cde67c906906783072a30b85e8d (patch)
tree4366676e73775f2094df62147613ba8f4b23ce60
parentae3ec3bce6e4847287db0c508ae723c8974d03ee (diff)
downloadaur-a247d44aee684cde67c906906783072a30b85e8d.tar.gz
added desktop file to pkgbuild
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c4db23077de..539ab92966b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = flashpoint-launcher-git
pkgdesc = Launcher for BlueMaxima's Flashpoint - Does not include data files! - Launcher software only.
- pkgver = e1b46166
- pkgrel = 3
+ pkgver = 10.0.0.e1b46166
+ pkgrel = 2
url = https://github.com/FlashpointProject/launcher
arch = x86_64
license = MIT
@@ -14,6 +14,8 @@ pkgbase = flashpoint-launcher-git
optdepends = flashplayer-standalone: native Flash support
conflicts = flashpoint-bin
source = flashpoint-launcher-git::git+https://github.com/FlashpointProject/launcher.git
+ source = flashpoint.desktop::https://aur.archlinux.org/cgit/aur.git/plain/flashpoint.desktop?h=flashpoint-launcher-git
sha256sums = SKIP
+ sha256sums = 2d9bc6f82f37d32267dbdde2778a626839b9936f75b711cd07bb79c477ceb0b8
pkgname = flashpoint-launcher-git
diff --git a/PKGBUILD b/PKGBUILD
index e11e47f67ca4..d4d1c3498039 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Colin Berry <colinb969@gmail.com>
pkgname=flashpoint-launcher-git
-pkgver=e1b46166
-pkgrel=3
+pkgver=10.0.0.e1b46166
+pkgrel=2
pkgdesc="Launcher for BlueMaxima's Flashpoint - Does not include data files! - Launcher software only."
arch=('x86_64')
url="https://github.com/FlashpointProject/launcher"
@@ -17,11 +17,13 @@ depends=('nss>=3.0'
optdepends=('flashplayer-standalone: native Flash support')
makedepends=('npm')
conflicts=('flashpoint-bin')
-source=("${pkgname}"::"git+https://github.com/FlashpointProject/launcher.git")
-sha256sums=('SKIP')
+source=("${pkgname}"::"git+https://github.com/FlashpointProject/launcher.git"
+ "flashpoint.desktop"::"https://aur.archlinux.org/cgit/aur.git/plain/flashpoint.desktop?h=flashpoint-launcher-git")
+sha256sums=('SKIP'
+ '2d9bc6f82f37d32267dbdde2778a626839b9936f75b711cd07bb79c477ceb0b8')
pkgver() {
cd "${srcdir}/${pkgname}"
- echo "$(git rev-parse --short HEAD)"
+ echo "10.0.0.$(git rev-parse --short HEAD)"
}
build(){
@@ -40,8 +42,8 @@ package(){
# Symlink to binary (WIP)
#ln -sf /opt/flashpoint/linux-unpacked/flashpoint-launcher $pkgdir/usr/bin/flashpoint-launcher
- # Desktop Entry (WIP)
- #install -Dm644 ./flashpoint.desktop "$pkgdir/usr/share/applications/flashpoint.desktop"
+ # Desktop Entry
+ install -Dm644 ${srcdir}/flashpoint.desktop "$pkgdir/usr/share/applications/flashpoint.desktop"
# License
install -Dm644 $srcdir/$pkgname/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"