summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuke Street2018-09-06 15:47:43 -0400
committerLuke Street2018-09-06 15:47:43 -0400
commita4120e29eac8f9bae9e1e8092f6b3bd7bbf78aec (patch)
tree4d252a5dec8bdc3a5cab8ef14a931e2c5d027bc8
parent1fb850cb96de67f2003a0f150ce1c186571aef42 (diff)
downloadaur-a4120e29eac8f9bae9e1e8092f6b3bd7bbf78aec.tar.gz
Remove libusb patch (fixed upstream)
-rw-r--r--.SRCINFO4
-rw-r--r--0001-digilent_spi-Avoid-deprecated-libusb-function.patch31
-rw-r--r--PKGBUILD9
3 files changed, 4 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb8b081ba752..db61a064a83a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = flashrom-git
pkgdesc = Flashrom is a utility which can be used to detect, read, erase, or write BIOS chips (DIP, PLCC, SPI).
- pkgver = p1.0.r85.gb2154e8
+ pkgver = p1.0.r99.g7ecfe48
pkgrel = 1
url = https://github.com/flashrom/flashrom
arch = aarch64
@@ -18,9 +18,7 @@ pkgbase = flashrom-git
conflicts = flashrom
replaces = flashrom-svn
source = git://github.com/flashrom/flashrom#branch=master
- source = 0001-digilent_spi-Avoid-deprecated-libusb-function.patch
sha512sums = SKIP
- sha512sums = 6930c34dcd5bc0079d4530bce5543d49492af834a794ca8569c1cccc40b6771c86936cdec05e06dd6fca60c27599af33afcf5eb6d8b5c4894736aa183ffbadb9
pkgname = flashrom-git
diff --git a/0001-digilent_spi-Avoid-deprecated-libusb-function.patch b/0001-digilent_spi-Avoid-deprecated-libusb-function.patch
deleted file mode 100644
index 51ab04afa880..000000000000
--- a/0001-digilent_spi-Avoid-deprecated-libusb-function.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 5a5097b2c2295031b4e170c27beddcc7116be420 Mon Sep 17 00:00:00 2001
-From: Luke Street <luke.street@encounterpc.com>
-Date: Tue, 26 Jun 2018 18:37:35 +0000
-Subject: [PATCH] digilent_spi: Avoid deprecated libusb function
-
-Same logic used in ch341a_spi (291764a70e6d8b212680e311bfb0825abf2b9a2f)
-
-Change-Id: I3546760ab70a5700b739bcaae8f1591730c172dc
----
- digilent_spi.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/digilent_spi.c b/digilent_spi.c
-index 458e1b6..d42c90f 100644
---- a/digilent_spi.c
-+++ b/digilent_spi.c
-@@ -386,7 +386,11 @@ int digilent_spi_init(void)
- return -1;
- }
-
-+#if LIBUSB_API_VERSION < 0x01000106
- libusb_set_debug(NULL, 3);
-+#else
-+ libusb_set_option(NULL, LIBUSB_OPTION_LOG_LEVEL, LIBUSB_LOG_LEVEL_INFO);
-+#endif
-
- uint16_t vid = devs_digilent_spi[0].vendor_id;
- uint16_t pid = devs_digilent_spi[0].device_id;
---
-2.17.0
-
diff --git a/PKGBUILD b/PKGBUILD
index ddbad0476b35..ec81a7eb6dbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,18 +10,16 @@ _gitauthor=flashrom
pkgdesc="Flashrom is a utility which can be used to detect, read, erase, or write BIOS chips (DIP, PLCC, SPI)."
url="https://github.com/${_gitauthor}/${_gitname}"
license=('GPL')
-source=("git://github.com/${_gitauthor}/${_gitname}#branch=${_gitbranch}"
- '0001-digilent_spi-Avoid-deprecated-libusb-function.patch')
+source=("git://github.com/${_gitauthor}/${_gitname}#branch=${_gitbranch}")
depends=('libftdi-compat' 'libusb' 'pciutils')
makedepends=('git')
optdepends=("dmidecode: for SMBIOS/DMI table decoder support")
conflicts=("${_gitname}")
provides=("${_gitname}")
replaces=("${_gitname}-svn")
-sha512sums=('SKIP'
- '6930c34dcd5bc0079d4530bce5543d49492af834a794ca8569c1cccc40b6771c86936cdec05e06dd6fca60c27599af33afcf5eb6d8b5c4894736aa183ffbadb9')
+sha512sums=('SKIP')
arch=('aarch64' 'armv6h' 'armv7h' 'i686' 'x86_64')
-pkgver=p1.0.r85.gb2154e8
+pkgver=p1.0.r99.g7ecfe48
pkgrel=1
pkgver() {
@@ -35,7 +33,6 @@ pkgver() {
build() {
cd "${srcdir}/${_gitname}"
- patch -Np1 -i "../0001-digilent_spi-Avoid-deprecated-libusb-function.patch"
make
}