summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorksmt46992019-09-22 17:20:32 +0900
committerksmt46992019-09-22 17:20:32 +0900
commiteadb4fd4f2ab922912414581ff3cafc9e5d6e398 (patch)
tree8c971f0c2d46a242a730b395ff52f0289eb6c47b
downloadaur-eadb4fd4f2ab922912414581ff3cafc9e5d6e398.tar.gz
Initial import
-rw-r--r--.INSTALL15
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD27
3 files changed, 66 insertions, 0 deletions
diff --git a/.INSTALL b/.INSTALL
new file mode 100644
index 000000000000..c4db1f71ff29
--- /dev/null
+++ b/.INSTALL
@@ -0,0 +1,15 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-mime-database /usr/share/mime || true
+ update-desktop-database /usr/share/applications || true
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4cfb3da33404
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = flast
+ pkgdesc = Cross-platform browser based on Chromium.
+ pkgver = 4.8.3
+ pkgrel = 1
+ url = https://gitlab.com/Aoichaan0513/flast
+ arch = x86_64
+ license = GPL
+ depends = at-spi2-core
+ depends = desktop-file-utils
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libappindicator-gtk3
+ depends = libnotify
+ depends = libsecret
+ depends = libutil-linux
+ depends = libxss
+ depends = libxtst
+ depends = nss
+ depends = xdg-utils
+ source = http://aoichaan0513.xyz/flast/linux/x64/Stable/Flast_4.8.3_amd64.deb
+ md5sums = 5be3aa5d6bd829a9f79621cad64d5eb3
+
+pkgname = flast
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a212b6de7402
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Yang Niao <ksmt 4699 at gmail dot com>
+# Contributor: Aoichaan0513 <at Aoichaan0513>
+pkgname=flast
+pkgver=4.8.3
+pkgrel=1
+pkgdesc='Cross-platform browser based on Chromium.'
+arch=('x86_64')
+url='https://gitlab.com/Aoichaan0513/flast'
+license=('GPL')
+depends=('at-spi2-core' 'desktop-file-utils' 'gtk3' 'hicolor-icon-theme' 'libappindicator-gtk3' 'libnotify' 'libsecret' 'libutil-linux' 'libxss' 'libxtst' 'nss' 'xdg-utils')
+source=(
+ "http://aoichaan0513.xyz/flast/linux/x64/Stable/Flast_${pkgver}_amd64.deb"
+)
+md5sums=('5be3aa5d6bd829a9f79621cad64d5eb3')
+
+prepare() {
+ tar -xvf data.tar.xz
+}
+
+package() {
+ cp -r ${srcdir}/opt ${pkgdir}/opt
+ cp -r ${srcdir}/usr ${pkgdir}/usr
+ chmod -R 755 ${pkgdir}/*
+ mkdir -p "${pkgdir}/usr/bin"
+ touch ${pkgdir}/usr/bin/flast
+ ln -sf "${pkgdir}/opt/Flast/flast" "${pkgdir}/usr/bin/flast"
+}