summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlireza Ayinmehr2020-05-26 15:44:16 +0430
committerAlireza Ayinmehr2020-05-26 15:44:16 +0430
commit9cfff53f85ce7946ea4bc79e5307f9818251c0ee (patch)
treeb23e23f2a3465e4a7690169d581acc6f4c289e17
parente731aadbacaf91b2044acb07b737cc2d44606999 (diff)
downloadaur-9cfff53f85ce7946ea4bc79e5307f9818251c0ee.tar.gz
Add !strip, Change versioning
-rwxr-xr-x.SRCINFO7
-rwxr-xr-xPKGBUILD9
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c389d9b6c0a..7215e82ee49a 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = flat-remix-git
pkgdesc = Flat remix is a pretty simple icon theme inspired on material design.
- pkgver = r300.b88827c2
- pkgrel = 2
+ pkgver = VERSION
+ pkgrel = 1
url = https://drasite.com/flat-remix
arch = any
license = GPL3
makedepends = git
+ provides = flat-remix
+ conflicts = flat-remix
+ options = !strip
source = flat-remix-git::git+https://github.com/daniruiz/flat-remix.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e2127ae8eeeb..7bca851ca443 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,22 @@
# Maintainer: Alireza Ayinmehr <alireza.darksun@gmail.com>
pkgname="flat-remix-git"
-pkgver=r300.b88827c2
-pkgrel=2
+pkgver=VERSION
+pkgrel=1
pkgdesc="Flat remix is a pretty simple icon theme inspired on material design."
arch=('any')
+options=('!strip')
url="https://drasite.com/flat-remix"
license=('GPL3')
makedepends=('git')
+provides=('flat-remix')
+conflicts=('flat-remix')
source=("${pkgname}::git+https://github.com/daniruiz/flat-remix.git")
sha256sums=('SKIP')
pkgver () {
cd "${srcdir}/${pkgname}/"
- printf "r% s.% s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {