summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJameson Pugh2016-07-18 15:47:02 -0400
committerJameson Pugh2016-07-18 15:47:02 -0400
commit61a10099e0952296141901ca16d85fe0f4db3594 (patch)
tree99f08a49011342f7235bc258150355cf68f1955e
downloadaur-61a10099e0952296141901ca16d85fe0f4db3594.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8d2a3f986af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Mon Jul 18 19:46:50 UTC 2016
+pkgbase = flatbuffers-git
+ pkgdesc = An efficient cross platform serialization library for C++, with support for Java, C# and Go (git)
+ pkgver = r794.a69b19f
+ pkgrel = 1
+ url = http://google.github.io/flatbuffers/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ optdepends = go
+ optdepends = java-environment
+ optdepends = mono
+ provides = flatbuffers
+ conflicts = flatbuffers
+ source = git+https://github.com/google/flatbuffers.git
+ sha256sums = SKIP
+
+pkgname = flatbuffers-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e8bf8cb0cd4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=flatbuffers-git
+pkgver=r794.a69b19f
+pkgrel=1
+pkgdesc='An efficient cross platform serialization library for C++, with support for Java, C# and Go (git)'
+arch=('i686' 'x86_64')
+url='http://google.github.io/flatbuffers/'
+license=('GPL')
+makedepends=('cmake' 'git')
+optdepends=('go' 'java-environment' 'mono')
+conflicts=(flatbuffers)
+provides=(flatbuffers)
+source=("git+https://github.com/google/flatbuffers.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd flatbuffers
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../flatbuffers \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+check() {
+ cd build
+ make test
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}