summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLee Mracek2022-06-14 20:31:11 -0400
committerLee Mracek2022-06-14 20:31:11 -0400
commita4f50eedf6612cff4f32a16c6d9f35a02de2f3bd (patch)
treedd9070efaeaaecdda9fb7ebed223378651743ebe
parent2ed9aa446d472ca60f1c5e0646a7963cd5a5f918 (diff)
downloadaur-a4f50eedf6612cff4f32a16c6d9f35a02de2f3bd.tar.gz
Fix patch against newer vrsions
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--remove-nested-verifier-test.patch3
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 790f46713bc7..4a7766a1d6aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = flatbuffers-git
pkgdesc = An efficient cross platform serialization library for C++, with support for Java, C# and Go
- pkgver = 2.0.6.r107.g967df08b
- pkgrel = 2
+ pkgver = 2.0.6.r118.g987aa5b5
+ pkgrel = 1
url = https://google.github.io/flatbuffers/
arch = x86_64
license = Apache
@@ -12,15 +12,15 @@ pkgbase = flatbuffers-git
source = git+https://github.com/google/flatbuffers
source = remove-nested-verifier-test.patch
sha256sums = SKIP
- sha256sums = 1c9b01f82312e3974acf6551e90cca9d4bd3e06b0877f1ad223a95163e9a3a26
+ sha256sums = 62993fce5b8fe683fc5ea61c60376b385764afc28e95cfb2094494df184d61ba
pkgname = flatbuffers-git
- provides = flatbuffers=2.0.6.r107.g967df08b
+ provides = flatbuffers=2.0.6.r118.g987aa5b5
conflicts = flatbuffers
pkgname = python-flatbuffers-git
pkgdesc = An efficient cross platform serialization library for Python
arch = any
depends = python
- provides = python-flatbuffers=2.0.6.r107.g967df08b
+ provides = python-flatbuffers=2.0.6.r118.g987aa5b5
conflicts = python-flatbuffers
diff --git a/PKGBUILD b/PKGBUILD
index 59bf9ffedeea..09dd7c8d641b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgbase=flatbuffers-git
_gitbase=flatbuffers
pkgname=(flatbuffers-git python-flatbuffers-git)
-pkgver=2.0.6.r107.g967df08b
-pkgrel=2
+pkgver=2.0.6.r118.g987aa5b5
+pkgrel=1
pkgdesc='An efficient cross platform serialization library for C++, with support for Java, C# and Go'
arch=(x86_64)
url='https://google.github.io/flatbuffers/'
@@ -15,7 +15,7 @@ makedepends=(cmake git python-setuptools)
source=(git+https://github.com/google/flatbuffers remove-nested-verifier-test.patch)
sha256sums=(
'SKIP'
- '1c9b01f82312e3974acf6551e90cca9d4bd3e06b0877f1ad223a95163e9a3a26'
+ '62993fce5b8fe683fc5ea61c60376b385764afc28e95cfb2094494df184d61ba'
)
pkgver() {
diff --git a/remove-nested-verifier-test.patch b/remove-nested-verifier-test.patch
index b61b6cd8f113..28b323fcce98 100644
--- a/remove-nested-verifier-test.patch
+++ b/remove-nested-verifier-test.patch
@@ -1,11 +1,12 @@
diff --git a/tests/test.cpp b/tests/test.cpp
--- a/tests/test.cpp
+++ b/tests/test.cpp
-@@ -4424,7 +4424,7 @@ int FlatBufferTests() {
+@@ -4424,8 +4424,8 @@ int FlatBufferTests() {
FixedLengthArraySpanTest();
StructUnionTest();
WarningsAsErrorsTest();
- NestedVerifierTest();
+ // NestedVerifierTest();
+ PrivateAnnotationsLeaks();
return 0;
}