summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLee Mracek2020-02-05 11:08:05 -0500
committerLee Mracek2020-02-05 11:08:05 -0500
commitc51e9239b159e7e59736fd19c0ac831bb28915f8 (patch)
tree0aa4aa74efd1240a3bd2e85f73b45e1d51b661e2
parent22ec4b817fe5254243e330a94ccb14336c369bb2 (diff)
downloadaur-c51e9239b159e7e59736fd19c0ac831bb28915f8.tar.gz
Update pkgbase variable
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 65ef89dd218e..e5e1dadf23aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Lee Mracek <lee@leemracek.com>
# Contributor: Jameson Pugh <imntreal@gmail.com>
-pkgbase=flatbuffers
+pkgbase=flatbuffers-git
+_gitbase=flatbuffers
pkgname=(flatbuffers-git python-flatbuffers-git)
pkgver=1856
pkgrel=1
@@ -15,16 +16,16 @@ source=(git+https://github.com/google/flatbuffers)
sha256sums=('SKIP')
pkgver() {
- cd ${srcdir}/${pkgbase}
+ cd ${srcdir}/${_gitbase}
git rev-list --count HEAD
}
prepare() {
- sed -i 's/-Werror=/-W/g;s/-Werror//g' $pkgbase/CMakeLists.txt
+ sed -i 's/-Werror=/-W/g;s/-Werror//g' $_gitbase/CMakeLists.txt
}
build() {
- cd $pkgbase
+ cd $_gitbase
cmake . \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -33,12 +34,12 @@ build() {
make
# Python bindings
- cd ../$pkgbase/python
+ cd ../$_gitbase/python
VERSION=$pkgver python setup.py build
}
check() {
- cd $pkgbase
+ cd $_gitbase
make test
./tests/PythonTest.sh
}
@@ -46,7 +47,7 @@ check() {
package_flatbuffers-git() {
conflicts=('flatbuffers')
provides=('flatbuffers')
- cd $pkgbase
+ cd $_gitbase
make DESTDIR="$pkgdir" install
install -Dm755 flatc -t "$pkgdir"/usr/bin
}
@@ -57,6 +58,6 @@ package_python-flatbuffers-git() {
depends=(python)
provides=('python-flatbuffers')
- cd $pkgbase/python
+ cd $_gitbase/python
VERSION=$pkgver python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}