summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake2016-02-13 22:56:18 +0100
committerJake2016-02-13 22:56:18 +0100
commit19d736e73f1d5ba410ccad9273bcedd5dfcb770a (patch)
tree7484f1d828b35e0efb9edea2e0f2a79ef8d8422b
downloadaur-19d736e73f1d5ba410ccad9273bcedd5dfcb770a.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD43
-rw-r--r--flatcam-git2
-rw-r--r--flatcam-git.desktop5
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c46fa6fe6b41
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Sat Feb 13 21:55:29 UTC 2016
+pkgbase = flatcam-git
+ pkgdesc = Generates CNC gcode from 2D PCB files (Gerber/Excellon/SVG)
+ pkgver = 8.4
+ pkgrel = 1
+ url = flatcam.org
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python2-simplejson
+ depends = python2-pyqt4
+ depends = python2-scipy
+ depends = python2-matplotlib
+ depends = python2-shapely
+ depends = python2-rtree
+ provides = flatcam
+ conflicts = flatcam
+ source = git+https://bitbucket.org/jpcgt/flatcam.git
+ source = flatcam-git
+ source = flatcam-git.desktop
+ md5sums = SKIP
+ md5sums = 80700f0bb07c959dc3019d9664472387
+ md5sums = e6496ad0b956d83fbe0e28a3b94e6c4f
+
+pkgname = flatcam-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b758c30ecb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=flatcam-git
+_pkgname=FlatCAM
+pkgver=8.4
+pkgrel=1
+pkgdesc="Generates CNC gcode from 2D PCB files (Gerber/Excellon/SVG)"
+arch=('any')
+url="flatcam.org"
+license=('MIT')
+depends=('python2-simplejson' 'python2-pyqt4' 'python2-scipy' 'python2-matplotlib' 'python2-shapely' 'python2-rtree')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://bitbucket.org/jpcgt/flatcam.git"
+ "$pkgname"
+ "$pkgname.desktop")
+md5sums=('SKIP'
+ '80700f0bb07c959dc3019d9664472387'
+ 'e6496ad0b956d83fbe0e28a3b94e6c4f')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ # Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ python2 -O -m py_compile *.py
+}
+
+
+package() {
+ install -D -m755 "$pkgname" "$pkgdir/usr/bin/${pkgname%-git}"
+ install -D -m644 "$pkgname.desktop" "$pkgdir/usr/share/applications/${pkgname%-git}.desktop"
+ cd "$srcdir/${pkgname%-git}"
+ install -D -m644 "share/flatcam_icon256.png" "$pkgdir/usr/share/pixmaps/${pkgname%-git}.png"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ rm -r *.sh doc FlatCAM_GTK
+ mkdir -p "${pkgdir}/opt/${pkgname%-git}"
+ cp -r * "${pkgdir}/opt/${pkgname%-git}"
+}
diff --git a/flatcam-git b/flatcam-git
new file mode 100644
index 000000000000..01b41910386b
--- /dev/null
+++ b/flatcam-git
@@ -0,0 +1,2 @@
+#!/bin/sh
+python2 /opt/flatcam/FlatCAM.pyo \ No newline at end of file
diff --git a/flatcam-git.desktop b/flatcam-git.desktop
new file mode 100644
index 000000000000..f8e1f23e9cc9
--- /dev/null
+++ b/flatcam-git.desktop
@@ -0,0 +1,5 @@
+[Desktop Entry]
+Name=FlatCAM
+Exec=flatcam
+Icon=flatcam
+Type=Application \ No newline at end of file