summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYann Büchau2021-04-10 15:05:23 +0200
committerYann Büchau2021-04-10 15:06:59 +0200
commit3a123393fab9b1b5ebe25ce755d65753bc966848 (patch)
treebadc800682d5d6634871c03b83dad6963ca9aa76
parent3635471991705821d081bbe50f0c5e679fd9d05e (diff)
downloadaur-3a123393fab9b1b5ebe25ce755d65753bc966848.tar.gz
Introduce FlatCAM MIME type
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD16
-rw-r--r--flatcam-git.desktop4
-rw-r--r--flatcam.xml9
5 files changed, 30 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cf1570bdf28..3fa5d0a10e36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = flatcam-git
pkgdesc = Generates CNC gcode from 2D PCB files (Gerber/Excellon/SVG)
- pkgver = r3435.a8a2f6b0
+ pkgver = r3472.a64d01b5
pkgrel = 1
url = http://flatcam.org
arch = any
@@ -30,13 +30,16 @@ pkgbase = flatcam-git
depends = python-lxml
depends = python-cycler
depends = python-qrcode
+ depends = hicolor-icon-theme
provides = flatcam
conflicts = flatcam
source = git+https://bitbucket.org/jpcgt/flatcam.git
source = flatcam-git.desktop
+ source = flatcam.xml
source = flatcam.sh
md5sums = SKIP
- md5sums = 75964eb8fb5d9fbb3da848edbf52af7a
+ md5sums = 8a0be1fc39b87116cba4162dc1257e2e
+ md5sums = e4a7f457350aa2e1c62cbe43f3b23e90
md5sums = ff3e92a98fa93954cfaf6c5d62a05643
pkgname = flatcam-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..56568bb1a34d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+flatcam*/
+src/
+pkg/
+*.pkg*
diff --git a/PKGBUILD b/PKGBUILD
index 460864eb931d..5fd3ac46ac6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jake <ja.ke@posteo.de>
pkgname=flatcam-git
_pkgname=FlatCAM
-pkgver=r3435.a8a2f6b0
+pkgver=r3472.a64d01b5
pkgrel=1
pkgdesc="Generates CNC gcode from 2D PCB files (Gerber/Excellon/SVG)"
arch=('any')
@@ -32,15 +32,18 @@ depends=('tk'
'python-lxml'
'python-cycler'
'python-qrcode'
+ 'hicolor-icon-theme'
)
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("git+https://bitbucket.org/jpcgt/flatcam.git"
"$pkgname.desktop"
+ "${pkgname%-git}.xml"
"${pkgname%-git}.sh")
md5sums=('SKIP'
- '75964eb8fb5d9fbb3da848edbf52af7a'
+ '8a0be1fc39b87116cba4162dc1257e2e'
+ 'e4a7f457350aa2e1c62cbe43f3b23e90'
'ff3e92a98fa93954cfaf6c5d62a05643')
prepare() {
@@ -60,15 +63,16 @@ build() {
package() {
- mkdir -p "$pkgdir/usr/bin/"
+ mkdir -p "$pkgdir/usr/bin/"
ln -s "/opt/${pkgname%-git}/${pkgname%-git}" "$pkgdir/usr/bin/${pkgname%-git}"
install -D -m644 "$pkgname.desktop" "$pkgdir/usr/share/applications/${pkgname%-git}.desktop"
+ install -D -m644 "${pkgname%-git}.xml" -t "$pkgdir/usr/share/mime/packages/"
install -D -m755 "${pkgname%-git}.sh" "$pkgdir/usr/bin/${pkgname%-git}"
cd "$srcdir/${pkgname%-git}"
- install -D -m644 "assets/linux/icon.png" "$pkgdir/usr/share/pixmaps/${pkgname%-git}.png"
+ install -D -m644 "assets/linux/icon.png" "$pkgdir/usr/share/icons/hicolor/128x128/apps/${pkgname%-git}.png"
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- rm -r *.sh doc tests
+
+ rm -rf *.sh doc tests
mkdir -p "${pkgdir}/opt/${pkgname%-git}"
cp -r * "${pkgdir}/opt/${pkgname%-git}"
}
diff --git a/flatcam-git.desktop b/flatcam-git.desktop
index 2a1a1032a1f0..7901d8e1c3f6 100644
--- a/flatcam-git.desktop
+++ b/flatcam-git.desktop
@@ -1,9 +1,9 @@
[Desktop Entry]
Categories=Development
-Exec=flatcam
+Exec=flatcam %U
Comment=Generates CNC gcode from 2D PCB files (Gerber/Excellon/SVG)
Icon=flatcam
-MimeType=
+MimeType=application/x-flatcam-project
Name=FlatCAM
Path=
StartupNotify=true
diff --git a/flatcam.xml b/flatcam.xml
new file mode 100644
index 000000000000..91061ddd8a06
--- /dev/null
+++ b/flatcam.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="application/x-flatcam-project">
+ <comment>FlatCAM Project</comment>
+ <comment xml:lang="de">FlatCAM-Projekt</comment>
+ <glob pattern="*.FlatPrj"/>
+ <icon name="flatcam"/>
+ </mime-type>
+</mime-info>