summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake2017-10-20 20:13:52 +0200
committerJake2017-10-20 20:13:52 +0200
commitaee7e56b6fb511f838ee8fc874a385b30db8d738 (patch)
tree01ec36e4956ebd2b104871d4ff0bab60b96b945d
parent77cafd304ee1b4516049c9fe7b3b7b6be7a3e04b (diff)
downloadaur-aee7e56b6fb511f838ee8fc874a385b30db8d738.tar.gz
Fixes for recent versions
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--flatcam-git2
3 files changed, 5 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16ce03123738..503ffdf65cc3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon Feb 29 15:40:25 UTC 2016
pkgbase = flatcam-git
pkgdesc = Generates CNC gcode from 2D PCB files (Gerber/Excellon/SVG)
- pkgver = r336.3280427
+ pkgver = r501.a9a4ec7
pkgrel = 1
url = http://flatcam.org
arch = any
@@ -19,10 +17,8 @@ pkgbase = flatcam-git
provides = flatcam
conflicts = flatcam
source = git+https://bitbucket.org/jpcgt/flatcam.git
- source = flatcam-git
source = flatcam-git.desktop
md5sums = SKIP
- md5sums = 80700f0bb07c959dc3019d9664472387
md5sums = 75964eb8fb5d9fbb3da848edbf52af7a
pkgname = flatcam-git
diff --git a/PKGBUILD b/PKGBUILD
index bb41d2cc35ad..8625db2ddb8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jake <ja.ke@posteo.de>
pkgname=flatcam-git
_pkgname=FlatCAM
-pkgver=r336.3280427
+pkgver=r501.a9a4ec7
pkgrel=1
pkgdesc="Generates CNC gcode from 2D PCB files (Gerber/Excellon/SVG)"
arch=('any')
@@ -12,10 +12,8 @@ makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("git+https://bitbucket.org/jpcgt/flatcam.git"
- "$pkgname"
"$pkgname.desktop")
md5sums=('SKIP'
- '80700f0bb07c959dc3019d9664472387'
'75964eb8fb5d9fbb3da848edbf52af7a')
pkgver() {
@@ -31,13 +29,14 @@ build() {
package() {
- install -D -m755 "$pkgname" "$pkgdir/usr/bin/${pkgname%-git}"
+ mkdir -p "$pkgdir/usr/bin/"
+ ln -s "${pkgdir}/opt/${pkgname%-git}/${pkgname%-git}" "$pkgdir/usr/bin/${pkgname%-git}"
install -D -m644 "$pkgname.desktop" "$pkgdir/usr/share/applications/${pkgname%-git}.desktop"
cd "$srcdir/${pkgname%-git}"
install -D -m644 "share/flatcam_icon256.png" "$pkgdir/usr/share/pixmaps/${pkgname%-git}.png"
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- rm -r *.sh doc FlatCAM_GTK
+ rm -r *.sh doc tests sandbox bugs
mkdir -p "${pkgdir}/opt/${pkgname%-git}"
cp -r * "${pkgdir}/opt/${pkgname%-git}"
}
diff --git a/flatcam-git b/flatcam-git
deleted file mode 100644
index 01b41910386b..000000000000
--- a/flatcam-git
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-python2 /opt/flatcam/FlatCAM.pyo \ No newline at end of file