diff options
author | Dee.H.Y | 2024-09-30 11:09:25 +0800 |
---|---|---|
committer | Dee.H.Y | 2024-09-30 11:09:29 +0800 |
commit | 7adb61680820c60096267ec2505891a15ee21f40 (patch) | |
tree | 6b5f3fbe26d62883600ba4ac6a3bd1a24a73d096 | |
parent | ec12665636f0e57162918b353ae03759cb14e920 (diff) | |
download | aur-7adb61680820c60096267ec2505891a15ee21f40.tar.gz |
bump to 0.8.62-3
Set rpath using patchelf.
-rw-r--r-- | .SRCINFO | 3 | ||||
-rw-r--r-- | PKGBUILD | 17 |
2 files changed, 17 insertions, 3 deletions
@@ -1,11 +1,12 @@ pkgbase = flclash-bin pkgdesc = A multi-platform proxy client based on ClashMeta,simple and easy to use, open-source and ad-free. pkgver = 0.8.62 - pkgrel = 2 + pkgrel = 3 url = https://github.com/chen08209/FlClash install = flclash.install arch = x86_64 license = GPL-3.0-only + makedepends = patchelf depends = cairo depends = at-spi2-core depends = hicolor-icon-theme @@ -2,7 +2,7 @@ pkgname=flclash-bin _pkgname=flclash pkgver=0.8.62 -pkgrel=2 +pkgrel=3 pkgdesc="A multi-platform proxy client based on ClashMeta,simple and easy to use, open-source and ad-free." arch=('x86_64') url="https://github.com/chen08209/FlClash" @@ -30,6 +30,9 @@ optdepends=( 'libayatana-appindicator: Display tray icon' 'libkeybinder3: Multimedia key support under non Gnome setups' ) +makedepends=( + 'patchelf' +) source=( "${_pkgname}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-amd64.deb" ) @@ -39,5 +42,15 @@ package() { msg "Converting debian package..." cd "$srcdir" tar -I zstd -xvf data.tar.zst -C "$pkgdir" - find "$pkgdir" -type d -exec chmod 755 {} \; + + # runpath + patchelf --set-rpath '$ORIGIN/lib' "$pkgdir"/usr/share/FlClash/FlClash + for i in "$pkgdir"/usr/share/FlClash/lib/*.so; do + echo "find so $i" + [ -z "$(patchelf --print-rpath "$i")" ] && continue + patchelf --set-rpath '$ORIGIN' "$i" + done + + # permissions + chmod -R u+rwX,go+rX,go-w "$pkgdir/" } |