summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSébastien Leduc2015-09-16 13:11:46 +0200
committerSébastien Leduc2015-09-16 13:11:46 +0200
commit4e63cf01f9db35ec0ca0f148ce099e66a6da8166 (patch)
tree1d0928f028edaac5d7eba7a2b757cfbbf8e89334
parent4b2b5ce354bbb82fc67779d88d1467e01f005df6 (diff)
downloadaur-4e63cf01f9db35ec0ca0f148ce099e66a6da8166.tar.gz
Bump to 1.2.351 + add patch to bypass the requirement beautifulsoup4 < 4.4
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--fix_beautifulsoup_4_4_0.patch11
3 files changed, 23 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cca1084356e1..215f8431c0a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = flexget
pkgdesc = Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more.
- pkgver = 1.2.350
+ pkgver = 1.2.351
pkgrel = 1
url = http://flexget.com/
changelog = ChangeLog
@@ -31,12 +31,14 @@ pkgbase = flexget
optdepends = python2-transmissionrpc: Transmission support
optdepends = python2-cherrypy: web interface
optdepends = python2-flask: web interface
- source = https://pypi.python.org/packages/source/F/FlexGet/FlexGet-1.2.350.tar.gz
+ source = https://pypi.python.org/packages/source/F/FlexGet/FlexGet-1.2.351.tar.gz
source = flexget.service
source = http://download.flexget.com/ChangeLog
- sha256sums = 1580c8e2a33c6967de48c823b0565cf03a10b20afcc19cea46d78fa58f377fbf
+ source = fix_beautifulsoup_4_4_0.patch
+ sha256sums = 652c46f835eeee6caf1a33596777e6baa1553b184150930e53f1d745ae0cf962
sha256sums = e2c3a958ed0c286337cd37fba1d6cbdf4306c57fcddf2b9cc43615ce80ae83aa
sha256sums = dcc1bc676b8c2b798fa9a7e0ed2b6853323e9e9d8ff696696dddeaf29cbc13d6
+ sha256sums = 7d65e71ea411f12fd6fb7ed4aa859ab21c83882d68abc78c8a0e8dbd4a96b7b4
pkgname = flexget
diff --git a/PKGBUILD b/PKGBUILD
index da032295479b..4cf06f2286ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=flexget
_pkgname=FlexGet
-pkgver=1.2.350
+pkgver=1.2.351
pkgrel=1
pkgdesc="Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more."
@@ -48,19 +48,23 @@ makedepends=('python2-paver'
source=("https://pypi.python.org/packages/source/F/FlexGet/${_pkgname}-${pkgver}.tar.gz"
'flexget.service'
"http://download.flexget.com/ChangeLog"
+ "fix_beautifulsoup_4_4_0.patch"
)
changelog=ChangeLog
-sha256sums=('1580c8e2a33c6967de48c823b0565cf03a10b20afcc19cea46d78fa58f377fbf'
+sha256sums=('652c46f835eeee6caf1a33596777e6baa1553b184150930e53f1d745ae0cf962'
'e2c3a958ed0c286337cd37fba1d6cbdf4306c57fcddf2b9cc43615ce80ae83aa'
- 'dcc1bc676b8c2b798fa9a7e0ed2b6853323e9e9d8ff696696dddeaf29cbc13d6')
+ 'dcc1bc676b8c2b798fa9a7e0ed2b6853323e9e9d8ff696696dddeaf29cbc13d6'
+ '7d65e71ea411f12fd6fb7ed4aa859ab21c83882d68abc78c8a0e8dbd4a96b7b4')
prepare() {
cd "${_pkgname}"-"${pkgver}"
msg "Patching shebangs to point to python2"
sed -i 's/\(python\)/\12/' flexget{,/ui}/__init__.py
+
+ patch < "${srcdir}"/fix_beautifulsoup_4_4_0.patch
}
package() {
diff --git a/fix_beautifulsoup_4_4_0.patch b/fix_beautifulsoup_4_4_0.patch
new file mode 100644
index 000000000000..283af6c7af2c
--- /dev/null
+++ b/fix_beautifulsoup_4_4_0.patch
@@ -0,0 +1,11 @@
+--- pavement.py 2015-09-03 08:12:10.000000000 +0200
++++ pavement.py 2015-09-16 13:04:39.543483185 +0200
+@@ -25,7 +25,7 @@
+ # guessit 0.10.4 stops supporting python 2.6, the tests also start failing on 2.7
+ # Path keeps messing about with case, so anything under 6.2 will be broken now
+ install_requires = ['FeedParser>=5.1.3', 'SQLAlchemy >=0.7.5, !=0.9.0, <1.999', 'PyYAML',
+- 'beautifulsoup4>=4.1, !=4.2.0, <4.4', 'html5lib>=0.11', 'PyRSS2Gen', 'pynzb', 'progressbar', 'rpyc',
++ 'beautifulsoup4>=4.1, !=4.2.0', 'html5lib>=0.11', 'PyRSS2Gen', 'pynzb', 'progressbar', 'rpyc',
+ 'jinja2', 'requests>=1.0, !=2.4.0, <2.99', 'python-dateutil!=2.0, !=2.2', 'jsonschema>=2.0',
+ 'python-tvrage', 'tmdb3', 'path.py>=6.2', 'guessit>=0.9.3, <0.10.4', 'apscheduler']
+ if sys.version_info < (2, 7):