summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2018-11-18 13:19:34 -0500
committerredfish2018-11-18 13:19:34 -0500
commitea673fb5e610250ca29086bbf0aab3ce3980bf45 (patch)
treea3e3615c46974f517f2ed2b6590ce0fd7c0986de
parent7bc3b570c349219c1604b7ea1e9aaee3fd8456ae (diff)
downloadaur-ea673fb5e610250ca29086bbf0aab3ce3980bf45.tar.gz
update to 2.17.12
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e7892fc28ba..bc462d5a1df5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Sep 19 22:56:24 UTC 2018
+# Sun Nov 18 18:19:12 UTC 2018
pkgbase = flexget
pkgdesc = Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more.
- pkgver = 2.14.21
+ pkgver = 2.17.12
pkgrel = 1
url = http://flexget.com/
changelog = ChangeLog
@@ -23,8 +23,8 @@ pkgbase = flexget
depends = python-requests>=2.16.3
depends = python-dateutil>=2.5.3
depends = python-jsonschema>=2.0
- depends = python-path>=8.1.1
- depends = python-pathlib>=1.0
+ depends = python-path.py
+ depends = python-guessit
depends = python-rebulk
depends = python-apscheduler>=3.2.0
depends = python-terminaltables>=3.1.0
@@ -43,10 +43,10 @@ pkgbase = flexget
optdepends = python-transmissionrpc: Transmission support
optdepends = python-rarfile: decompress plugin
optdepends = python-boto3: SNS output plugin
- source = https://github.com/Flexget/Flexget/archive/2.14.21.tar.gz
+ source = https://github.com/Flexget/Flexget/archive/2.17.12.tar.gz
source = flexget.service
source = http://download.flexget.com/ChangeLog
- sha256sums = a4c5497278d48bc99d3bb545de6ef34d52491ecc2aa2cd37610a1b21badcebd7
+ sha256sums = 32354a5db0dc3fb3534b796d1f83001072636f23a71b880cefeda23025ff102d
sha256sums = e2c3a958ed0c286337cd37fba1d6cbdf4306c57fcddf2b9cc43615ce80ae83aa
sha256sums = dcc1bc676b8c2b798fa9a7e0ed2b6853323e9e9d8ff696696dddeaf29cbc13d6
diff --git a/PKGBUILD b/PKGBUILD
index 7c27acd63ead..773888b8cdf5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=flexget
_pkgname=Flexget
-pkgver=2.14.21
+pkgver=2.17.12
pkgrel=1
pkgdesc="Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more."
@@ -29,9 +29,8 @@ depends=('python'
'python-requests>=2.16.3'
'python-dateutil>=2.5.3'
'python-jsonschema>=2.0'
- 'python-path>=8.1.1'
- 'python-pathlib>=1.0'
- #'python-guessit' # feature disabled until upstream updates to latest API
+ 'python-path.py'
+ 'python-guessit'
'python-rebulk'
'python-apscheduler>=3.2.0'
'python-terminaltables>=3.1.0'
@@ -66,7 +65,7 @@ changelog=ChangeLog
prepare() {
cd "${_pkgname}"-"${pkgver}"
- #msg "Patching shebangs to point to python2"
+ #msg "Patching shebangs to point to python"
sed -i '1s/python2/python/' flexget{,/ui}/__init__.py
# Don't use the requirements.txt with pinned deps
@@ -82,6 +81,9 @@ prepare() {
# zxcvbn-python has been renamed zxcvbn
sed -i 's/zxcvbn-python/zxcvbn/' requirements.txt
+ # pathlib no longer required since python 3.4
+ sed -i 's/pathlib.*//' requirements.txt
+
# disable this parser because python-guessit API changed and upstream
# needs to be patched to support it.
rm flexget/plugins/parsers/parser_guessit.py
@@ -100,7 +102,7 @@ package() {
install -Dm644 ../flexget.service "${pkgdir}"/usr/lib/systemd/user/flexget.service
}
-sha256sums=('a4c5497278d48bc99d3bb545de6ef34d52491ecc2aa2cd37610a1b21badcebd7'
+sha256sums=('32354a5db0dc3fb3534b796d1f83001072636f23a71b880cefeda23025ff102d'
'e2c3a958ed0c286337cd37fba1d6cbdf4306c57fcddf2b9cc43615ce80ae83aa'
'dcc1bc676b8c2b798fa9a7e0ed2b6853323e9e9d8ff696696dddeaf29cbc13d6')
# vim:set ts=2 sw=2 et: