summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-03-20 13:26:34 -0400
committerGuillaume Horel2017-03-20 13:26:34 -0400
commitc1406e013d8cc4968a346533b11faadbd82d4fe7 (patch)
tree688acb49b5c450b97aa9e371a3e5fd42918d3914
parentd362d5d7986a7162db3bd60c9236b517438894f7 (diff)
downloadaur-c1406e013d8cc4968a346533b11faadbd82d4fe7.tar.gz
version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--flexisip.service9
3 files changed, 19 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60625cd25509..e95e9973fb31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,12 +11,14 @@ pkgbase = flexisip
depends = hiredis
depends = mediastreamer
depends = protobuf
- depends = sofia-sip-bc
+ depends = sofia-sip-bc>=1.13.12
depends = unixodbc
depends = xsd
depends = soci
- source = https://github.com/BelleDonneCommunications/flexisip/archive/1.0.10.tar.gz
- md5sums = aa42bc3fee319e731947c2e00dff4eb3
+ source = git+https://github.com/BelleDonneCommunications/flexisip.git#commit=cf47b79bd656
+ source = flexisip.service
+ sha256sums = SKIP
+ sha256sums = 2a96c6604c62ea6b70f0bd6e96c6910afef6e17ac8d44ce0a50cce60279946be
pkgname = flexisip
diff --git a/PKGBUILD b/PKGBUILD
index 7a908eb607a4..b798f4214347 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ arch=('i686' 'x86_64')
url="http://flexisip.org"
license=('AGPL3')
groups=()
-depends=('belle-sip' 'boost-libs' 'hiredis' 'mediastreamer' 'protobuf' 'sofia-sip-bc' 'unixodbc' 'xsd' 'soci')
+depends=('belle-sip' 'boost-libs' 'hiredis' 'mediastreamer' 'protobuf' 'sofia-sip-bc>=1.13.12' 'unixodbc' 'xsd' 'soci')
makedepends=()
optdepends=()
provides=()
@@ -17,12 +17,14 @@ backup=()
options=()
install=
changelog=
-source=("https://github.com/BelleDonneCommunications/$pkgname/archive/$pkgver.tar.gz")
+source=("git+https://github.com/BelleDonneCommunications/$pkgname.git#commit=cf47b79bd656"
+ "flexisip.service")
noextract=()
-md5sums=('aa42bc3fee319e731947c2e00dff4eb3')
+sha256sums=('SKIP'
+ '2a96c6604c62ea6b70f0bd6e96c6910afef6e17ac8d44ce0a50cce60279946be')
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
./autogen.sh
./configure --prefix=/usr \
@@ -42,7 +44,8 @@ build() {
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
make DESTDIR="$pkgdir/" install
+ install -Dm0644 "$srcdir/flexisip.service" "$pkgdir/usr/lib/systemd/system/flexisip.service"
}
diff --git a/flexisip.service b/flexisip.service
index 72e0d335c8c6..516ab2416a4e 100644
--- a/flexisip.service
+++ b/flexisip.service
@@ -1,8 +1,11 @@
[Unit]
-Description=
-After=network.service
+Description=Flexisip server
+After=network.target
[Service]
Type=forking
ExecStart=/usr/bin/flexisip --daemon -p /run/flexisip.pid
-PIDFile=/run/flexsip.pid
+PIDFile=/run/flexisip.pid
+
+[Install]
+WantedBy=multi-user.target