summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Schmitt2017-02-18 14:17:59 +0100
committerPhilipp Schmitt2017-02-18 14:17:59 +0100
commite383d6d8ca519770ab10148537e39f36b7951b4e (patch)
tree334036831a22e4480b775dce0de57189e45564d1
downloadaur-e383d6d8ca519770ab10148537e39f36b7951b4e.tar.gz
first commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
-rw-r--r--flicd.install6
-rw-r--r--flicd.service12
5 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..789037efb964
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Feb 18 13:17:48 UTC 2017
+pkgbase = flicd
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://github.com/50ButtonsEach/fliclib-linux-hci
+ install = flicd.install
+ arch = any
+ license = unknown
+ makedepends = make
+ backup = etc/flicd/db
+ source = git+https://github.com/50ButtonsEach/fliclib-linux-hci#tag=0.4
+ source = flicd.service
+ md5sums = SKIP
+ md5sums = 6144a880dd1975c63140f1754320812c
+ sha256sums = SKIP
+ sha256sums = 89c7f1872e84eb87b4e02f331819fbd40dadfaa99a8a2d1e255f225c2b1c0617
+
+pkgname = flicd
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7b7f77163026
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar*
+*.pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..799bf669802c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Philipp Schmitt <philipp@schmitt.co>
+# GitHub: https://github.com/pschmitt/aur-flicd
+pkgname=flicd
+pkgver=0.4
+pkgrel=1
+pkgdesc=""
+arch=('any')
+url="https://github.com/50ButtonsEach/fliclib-linux-hci"
+license=('unknown')
+source=("git+https://github.com/50ButtonsEach/fliclib-linux-hci#tag=0.4"
+ "flicd.service")
+makedepends=('make')
+md5sums=('SKIP'
+ '6144a880dd1975c63140f1754320812c')
+sha256sums=('SKIP'
+ '89c7f1872e84eb87b4e02f331819fbd40dadfaa99a8a2d1e255f225c2b1c0617')
+backup=('etc/flicd/db')
+install="${pkgname}.install"
+
+build() {
+ cd "${srcdir}/fliclib-linux-hci/simpleclient"
+ make
+}
+
+package() {
+ local cpu_arch
+ case "$CARCH" in
+ x86_64|i386)
+ cpu_arch="$CARCH" ;;
+ arm*)
+ cpu_arch=armv6l ;;
+ *)
+ echo "Unknown CPU architecture: $CARCH" >&2
+ exit 3
+ ;;
+ esac
+ cd "${srcdir}/fliclib-linux-hci"
+ install -Dm 755 "bin/${cpu_arch}/flicd" "${pkgdir}/usr/bin/flicd"
+ install -Dm 755 "simpleclient/simpleclient" \
+ "${pkgdir}/usr/bin/flic-simpleclient"
+ install -Dm 644 "${srcdir}/flicd.service" \
+ "${pkgdir}/usr/lib/systemd/system/flicd.service"
+ install -dDm 755 "${pkgdir}/etc/flicd"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/flicd.install b/flicd.install
new file mode 100644
index 000000000000..640d446f1232
--- /dev/null
+++ b/flicd.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo "To get started start the flicd.service"
+ echo "NOTE: The flicd service listens on all interfaces by default (port 5551)"
+ echo
+ echo "To test: \$ flic-simpleclient localhost"
+}
diff --git a/flicd.service b/flicd.service
new file mode 100644
index 000000000000..84e8d22598a2
--- /dev/null
+++ b/flicd.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=flicd
+After=network.target
+
+[Service]
+Type=simple
+Restart=always
+RestartSec=3
+ExecStart=/usr/bin/flicd -f /etc/flicd/db -s 0.0.0.0 -p 5551
+
+[Install]
+WantedBy=multi-user.target