summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFoppe Hemminga2015-07-07 13:17:22 +0200
committerFoppe Hemminga2015-07-07 13:17:22 +0200
commit7f19182334cf9df27134c9cae592b4e3b1813a2b (patch)
treedba6f0d57067a4fc58fadca0c7aa08a063c53f32
downloadaur-7f19182334cf9df27134c9cae592b4e3b1813a2b.tar.gz
Initial commit copy of AUR3
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25c27eac7a6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = flickrms
+ pkgdesc = Management of ones flickr photos and photosets directly from a POSIX compliant machine
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/patrickjennings/FlickrMS
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = fuse
+ depends = flickcurl
+ depends = pkg-config
+ depends = libxml2
+ depends = glib
+ depends = curl
+ source = flickrms::git+https://github.com/patrickjennings/FlickrMS
+ md5sums = SKIP
+
+pkgname = flickrms
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..270d90ae4979
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Foppe Hemminga <foppe@hemminga.net>
+pkgname=flickrms
+pkgver=1.0
+pkgrel=1
+pkgdesc="Management of ones flickr photos and photosets directly from a POSIX compliant machine"
+arch=('i686' 'x86_64')
+url="https://github.com/patrickjennings/FlickrMS"
+license=("Apache")
+#makedepends=()
+depends=('fuse' 'flickcurl' 'pkg-config' 'libxml2' 'glib' 'curl')
+source=("${pkgname%-*}::git+https://github.com/patrickjennings/FlickrMS")
+md5sums=('SKIP')
+
+pkgver () {
+ cd "$srcdir/${pkgname%-*}"
+ git describe --tags | sed 's|^v||'
+}
+
+build() {
+ cd "${srcdir}/${pkgname%-*}"
+ make
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin/"
+ cd "${srcdir}/${pkgname%-*}/src/"
+ cp flickrms "${pkgdir}/usr/bin/"
+} \ No newline at end of file