summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGlen D'souza2016-12-01 18:52:02 +0530
committerGlen D'souza2016-12-01 18:52:02 +0530
commitbc12caf6744c183f7ec5270222ac4b666f4d1a23 (patch)
tree6a9314f1c2a8c53ddb315ec5bc9a164e29b41c9e
parente589e2ab65c1306b72f97ed5d8ebca6c9d36fa1a (diff)
downloadaur-bc12caf6744c183f7ec5270222ac4b666f4d1a23.tar.gz
Fixed a stupid error with path
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de7cc27ac017..475f00701110 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Dec 1 09:59:01 UTC 2016
+# Thu Dec 1 13:21:49 UTC 2016
pkgbase = flightgear-git
pkgdesc = An open-source, multi-platform flight simulator
pkgver = 20161201
diff --git a/PKGBUILD b/PKGBUILD
index 4315bdcb047a..b91221ccc4e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,18 +36,18 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
../${_gitname}
- uudecode -o package/flightgear.png package/flightgear.png.uue
+ uudecode -o ../${_gitname}/package/flightgear.png ../${_gitname}/package/flightgear.png.uue
make || return 1
- sed -i 's|Exec=.*|Exec=fgfs --fg-root=/usr/share/flightgear --launcher|' package/flightgear.desktop
+ sed -i 's|Exec=.*|Exec=fgfs --fg-root=/usr/share/flightgear --launcher|' ../${_gitname}/package/flightgear.desktop
}
package(){
cd "${srcdir}/${_gitname}-build/"
make DESTDIR="$pkgdir" install
- install -Dm0644 package/flightgear.desktop $pkgdir/usr/share/applications/flightgear.desktop
- install -Dm0644 package/flightgear.ico $pkgdir/usr/share/icons/flightgear.ico
- install -Dm0644 package/flightgear.png $pkgdir/usr/share/icons/flightgear.png
- install -Dm0644 scripts/completion/fg-completion.bash $pkgdir/usr/share/bash-completion/completions/fgfs
+ install -Dm0644 ../${_gitname}/package/flightgear.desktop $pkgdir/usr/share/applications/flightgear.desktop
+ install -Dm0644 ../${_gitname}/package/flightgear.ico $pkgdir/usr/share/icons/flightgear.ico
+ install -Dm0644 ../${_gitname}/package/flightgear.png $pkgdir/usr/share/icons/flightgear.png
+ install -Dm0644 ../${_gitname}/scripts/completion/fg-completion.bash $pkgdir/usr/share/bash-completion/completions/fgfs
}