summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjmf2015-06-18 16:16:06 +0200
committerjmf2015-06-18 16:16:06 +0200
commitdd68f2039da2d4a4ab70c3f83b3dc9d21c764324 (patch)
treee8a7a1908be299a70a9be5cc8ceca7872ec23b3f
downloadaur-dd68f2039da2d4a4ab70c3f83b3dc9d21c764324.tar.gz
Update to new sourceforge mirror
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD48
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0013871e7553
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = flightgear-git
+ pkgdesc = An open-source, multi-platform flight simulator
+ pkgver = 20150613
+ pkgrel = 3
+ url = http://flightgear.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = boost
+ depends = simgear-git
+ depends = libxmu
+ depends = libxi
+ depends = zlib
+ depends = fgdata-git
+ depends = openscenegraph-git
+ provides = flightgear-git
+ conflicts = flightgear
+
+pkgname = flightgear-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd7dc30d0076
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Contributor: Pascal Groschwitz <p.groschwitz@googlemail.com>
+# Contributor: jmf <jmf at mesecons dot net>
+pkgname=flightgear-git
+pkgver=20150613
+pkgrel=3
+pkgdesc="An open-source, multi-platform flight simulator"
+arch=('i686' 'x86_64')
+url="http://flightgear.org/"
+license=('GPL')
+depends=('simgear-git' 'libxmu' 'libxi' 'zlib' 'fgdata-git' 'openscenegraph-git')
+optdepends=()
+makedepends=('git' 'boost')
+provides=('flightgear-git')
+conflicts=('flightgear')
+
+_gitroot="git://git.code.sf.net/p/flightgear/flightgear"
+_gitname="flightgear"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ git checkout next
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname
+ git checkout next
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ cmake ../flightgear -DCMAKE_INSTALL_PREFIX=/usr -DENABLE_QT=0 -DFG_DATA_DIR:STRING="/usr/share/flightgear" -DCMAKE_INSTALL_LIBDIR=/usr/lib -DCMAKE_BUILD_TYPE=Debug
+
+ make -j8 || return 1
+}
+
+package(){
+ cd "$srcdir/$_gitname-build"
+ make DESTDIR="$pkgdir/" install
+}
+