summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGlen D'souza2016-05-15 18:13:30 +0530
committerGlen D'souza2016-05-15 18:13:30 +0530
commitfeae1fb5d0a34979db6fd2da2e2bcfd0946979e2 (patch)
treebf0e377cef53705b184b33102903d3d425bf919f
parenta6214b91858152a39a848c86863ab084fe813499 (diff)
downloadaur-feae1fb5d0a34979db6fd2da2e2bcfd0946979e2.tar.gz
Fix build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--fix.patch11
3 files changed, 25 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c31a8c7069e..ea4047ca802f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Apr 16 11:43:55 UTC 2016
+# Sun May 15 12:42:39 UTC 2016
pkgbase = flightgear-git
pkgdesc = An open-source, multi-platform flight simulator
- pkgver = 20160416
+ pkgver = 20160515
pkgrel = 1
url = http://flightgear.org/
arch = i686
@@ -25,7 +25,9 @@ pkgbase = flightgear-git
provides = flightgear-git
conflicts = flightgear
source = git://git.code.sf.net/p/flightgear/flightgear
+ source = fix.patch
md5sums = SKIP
+ md5sums = a90265027eac1a61ec8f8eb5b6b4a03a
pkgname = flightgear-git
diff --git a/PKGBUILD b/PKGBUILD
index c8b1bebc40c5..8d7283f65d66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: jmf <jmf at mesecons dot net>
# Contributor: Pascal Groschwitz <p.groschwitz@googlemail.com>
pkgname=flightgear-git
-pkgver=20160416
+pkgver=20160515
pkgrel=1
_gitname=flightgear
pkgdesc="An open-source, multi-platform flight simulator"
@@ -14,13 +14,20 @@ optdepends=()
makedepends=('boost' 'cmake' 'mesa' 'sharutils' 'simgear-git')
provides=('flightgear-git')
conflicts=('flightgear')
-source=(git://git.code.sf.net/p/flightgear/flightgear)
-md5sums=('SKIP')
+source=(git://git.code.sf.net/p/flightgear/flightgear
+ fix.patch)
+md5sums=('SKIP'
+ 'a90265027eac1a61ec8f8eb5b6b4a03a')
pkgver() {
echo "$(date +"%Y%m%d")"
}
+prepare() {
+ cd ${srcdir}
+ patch -p0 -i fix.patch
+}
+
build() {
cd ${srcdir}/${_gitname}
git checkout next
diff --git a/fix.patch b/fix.patch
new file mode 100644
index 000000000000..ed758976dd9a
--- /dev/null
+++ b/fix.patch
@@ -0,0 +1,11 @@
+--- flightgear/src/Navaids/PositionedOctree.hxx 2016-05-15 18:05:44.904316000 +0530
++++ flightgear/src/Navaids/PositionedOctree.hxx 2016-05-15 18:06:27.696729611 +0530
+@@ -60,7 +60,7 @@
+ _order(x),
+ _inner(v)
+ {
+- assert(!isnan(x));
++ assert(!std::isnan(x));
+ }
+
+ Ordered(const Ordered<T>& a) :