summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-03-10 17:38:23 +0200
committerDimitris Kiziridis2020-03-10 17:38:23 +0200
commit45ee4e3624e130297159874f1a7731123c0e2375 (patch)
tree83744bd19b6716fc4a12f66ede121de2c2407261
downloadaur-45ee4e3624e130297159874f1a7731123c0e2375.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
-rw-r--r--flipper.desktop9
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fde7ab9fe94f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = flipper-bin
+ pkgdesc = A desktop debugging platform for mobile developers
+ pkgver = 0.33.1
+ pkgrel = 1
+ url = https://fbflipper.com/
+ arch = any
+ license = MIT
+ depends = gtk3
+ depends = libsecret
+ depends = libxss
+ depends = nss
+ optdepends = watchman: An inotify-based file watching and job triggering command line utility
+ optdepends = android-sdk: Android debugging support
+ provides = flipper
+ source = https://github.com/facebook/flipper/releases/download/v0.33.1/Flipper-linux.zip
+ source = flipper.desktop
+ sha256sums = 96dc62b4c0d1816ff87f5a3d26dbf16d2167fdf9d7cba27dcc37413574f45272
+ sha256sums = 38a9977cebac01bdda62dda1d1705a5e71b73e34fe3be5dc193b762b2c86bf15
+
+pkgname = flipper-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99e970a70671
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=flipper-bin
+pkgver=0.33.1
+pkgrel=1
+pkgdesc='A desktop debugging platform for mobile developers'
+arch=('any')
+url='https://fbflipper.com/'
+license=('MIT')
+provides=('flipper')
+depends=('gtk3' 'libsecret' 'libxss' 'nss')
+optdepends=('watchman: An inotify-based file watching and job triggering command line utility'
+ 'android-sdk: Android debugging support')
+source=("https://github.com/facebook/flipper/releases/download/v${pkgver}/Flipper-linux.zip"
+ 'flipper.desktop')
+sha256sums=('96dc62b4c0d1816ff87f5a3d26dbf16d2167fdf9d7cba27dcc37413574f45272'
+ '38a9977cebac01bdda62dda1d1705a5e71b73e34fe3be5dc193b762b2c86bf15')
+
+package() {
+ cd "${srcdir}"
+ rm Flipper-linux.zip
+ mkdir -p "${pkgdir}/opt/flipper"
+ mkdir -p "$pkgdir/usr/bin"
+ cp -r ${srcdir}/* ${pkgdir}/opt/flipper
+ ln -s ${pkgdir}/opt/flipper/flipper ${pkgdir}/usr/bin
+ install -Dm644 flipper.desktop ${pkgdir}/usr/share/applications/flipper.desktop
+ install -Dm644 ${srcdir}/resources/app/icon.png ${pkgdir}/usr/share/pixmaps/flipper.png
+ rm "${pkgdir}/opt/flipper"/flipper.desktop
+} \ No newline at end of file
diff --git a/flipper.desktop b/flipper.desktop
new file mode 100644
index 000000000000..5c62b4555742
--- /dev/null
+++ b/flipper.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Flipper
+Comment=A desktop debugging platform for mobile developers
+Icon=flipper
+Exec=flipper
+Categories=Application;Development;
+Terminal=false
+StartupNotify=false \ No newline at end of file