summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-12-03 11:27:12 +0100
committerPhilipp A2019-12-03 11:27:12 +0100
commit0282d1134f78f434e2929cfb52fed9c9107c6949 (patch)
treed0b2cab361bce2a60baa766adfaa6ce99d8e6595
parent633fde78cc4a6eaa74eca40d4ea92348d8de828e (diff)
downloadaur-0282d1134f78f434e2929cfb52fed9c9107c6949.tar.gz
rearchitecture
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 21 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39c6649eea6e..d5c0035be90a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
pkgbase = flit
pkgdesc = Simple packaging tool for simple Python packages.
pkgver = 2.1.0
- pkgrel = 1
+ pkgrel = 2
url = http://flit.readthedocs.io
arch = any
license = BSD
- makedepends = python-pip
+ makedepends = install-wheel-scripts
depends = python
depends = python-pytoml
depends = python-requests
depends = python-requests_download
depends = python-docutils
noextract = flit-2.1.0-py3-none-any.whl
+ noextract =
source = https://files.pythonhosted.org/packages/py3/f/flit/flit-2.1.0-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py2.py3/f/flit-core/flit_core-2.1.0-py2.py3-none-any.whl
sha256sums = 494e0806840fe896fe31ce2a413583115324f12177ecaf7427f157caa9b9c5b2
+ sha256sums = c6dff661e9e290d51084cefc38b0971d692290e8a352d0b6cec6006be764b4d1
pkgname = flit
diff --git a/PKGBUILD b/PKGBUILD
index 094a40f1cf37..6412a0b692b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,29 @@
pkgname=flit
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Simple packaging tool for simple Python packages.'
arch=('any')
url="http://$pkgname.readthedocs.io"
license=('BSD')
depends=(python python-pytoml python-requests python-requests_download python-docutils)
-makedepends=('python-pip')
-_wheel="$pkgname-$pkgver-py3-none-any.whl"
-source=("https://files.pythonhosted.org/packages/py3/${pkgname::1}/$pkgname/$_wheel")
-sha256sums=('494e0806840fe896fe31ce2a413583115324f12177ecaf7427f157caa9b9c5b2')
-noextract=("$_wheel")
+makedepends=(install-wheel-scripts)
+_wheel_cli="$pkgname-$pkgver-py3-none-any.whl"
+_wheel_core="${pkgname}_core-$pkgver-py2.py3-none-any.whl"
+source=(
+ "https://files.pythonhosted.org/packages/py3/${pkgname::1}/$pkgname/$_wheel_cli"
+ "https://files.pythonhosted.org/packages/py2.py3/${pkgname::1}/$pkgname-core/$_wheel_core"
+)
+sha256sums=(
+ '494e0806840fe896fe31ce2a413583115324f12177ecaf7427f157caa9b9c5b2'
+ 'c6dff661e9e290d51084cefc38b0971d692290e8a352d0b6cec6006be764b4d1'
+)
+noextract=("$_wheel_cli" "$wheel_core")
package() {
local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
mkdir -p "$site"
- unzip "$_wheel" -d "$site"
+ unzip "$_wheel_cli" -d "$site"
+ unzip "$_wheel_core" -d "$site"
+ install-wheel-scripts --prefix="$pkgdir/usr" "$_wheel_cli"
}