summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-12-03 11:14:14 +0100
committerPhilipp A2019-12-03 11:14:14 +0100
commit633fde78cc4a6eaa74eca40d4ea92348d8de828e (patch)
tree93cb2de9cca1a823769a0f1428a40b3ae9595c5f
parent0b1f38420bd1d8184250aa3d41d847b0e30d8561 (diff)
downloadaur-633fde78cc4a6eaa74eca40d4ea92348d8de828e.tar.gz
v2.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec9e6bf4b4a8..39c6649eea6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = flit
pkgdesc = Simple packaging tool for simple Python packages.
- pkgver = 1.3
+ pkgver = 2.1.0
pkgrel = 1
url = http://flit.readthedocs.io
arch = any
@@ -11,9 +11,9 @@ pkgbase = flit
depends = python-requests
depends = python-requests_download
depends = python-docutils
- noextract = flit-1.3-py3-none-any.whl
- source = https://files.pythonhosted.org/packages/py3/f/flit/flit-1.3-py3-none-any.whl
- sha256sums = 1d93f7a833ed8a6e120ddc40db5c4763bc39bccc75c05081ec8285ece718aefb
+ noextract = flit-2.1.0-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py3/f/flit/flit-2.1.0-py3-none-any.whl
+ sha256sums = 494e0806840fe896fe31ce2a413583115324f12177ecaf7427f157caa9b9c5b2
pkgname = flit
diff --git a/PKGBUILD b/PKGBUILD
index f96058442c67..094a40f1cf37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philipp A. <flying-sheep@web.de>
pkgname=flit
-pkgver=1.3
+pkgver=2.1.0
pkgrel=1
pkgdesc='Simple packaging tool for simple Python packages.'
arch=('any')
@@ -11,9 +11,11 @@ depends=(python python-pytoml python-requests python-requests_download python-do
makedepends=('python-pip')
_wheel="$pkgname-$pkgver-py3-none-any.whl"
source=("https://files.pythonhosted.org/packages/py3/${pkgname::1}/$pkgname/$_wheel")
-sha256sums=('1d93f7a833ed8a6e120ddc40db5c4763bc39bccc75c05081ec8285ece718aefb')
+sha256sums=('494e0806840fe896fe31ce2a413583115324f12177ecaf7427f157caa9b9c5b2')
noextract=("$_wheel")
package() {
- pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
}