summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2016-02-15 12:36:37 +0100
committerAlbert Graef2016-02-15 12:36:37 +0100
commit9e881c5cf44dca30965f55fde113837ff00ed67f (patch)
tree8584415ebf2c5c4daaa3b34fe022a4adcb0c5f9c
parent5a7f63e8ab834e006b1983e6422f96d3b0e63543 (diff)
downloadaur-9e881c5cf44dca30965f55fde113837ff00ed67f.tar.gz
Applied changes by g2oo7fy.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--flite-fpic.patch16
3 files changed, 31 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b05becdf1212..cc317fd9da6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Mon Feb 15 11:34:07 UTC 2016
pkgbase = flite-fpic
pkgdesc = A lighweight version of festival speech synthesis compiled with -fPIC
pkgver = 1.4
- pkgrel = 6
+ pkgrel = 7
url = http://www.speech.cs.cmu.edu/flite/
arch = i686
arch = x86_64
@@ -12,7 +14,9 @@ pkgbase = flite-fpic
provides = flite-fpic
replaces = flite
source = http://www.festvox.org/flite/packed/flite-1.4/flite-1.4-release.tar.bz2
+ source = flite-fpic.patch
md5sums = b7c3523b3bbc6f29ce61e6650cd9a428
+ md5sums = d818853cb4e416b76457ed63df7fde9c
pkgname = flite-fpic
diff --git a/PKGBUILD b/PKGBUILD
index bda2080a6149..8ad8ef099b05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=flite-fpic
_pkgname=flite
pkgver=1.4
-pkgrel=6
+pkgrel=7
pkgdesc="A lighweight version of festival speech synthesis compiled with -fPIC"
arch=('i686' 'x86_64')
url="http://www.speech.cs.cmu.edu/flite/"
@@ -11,8 +11,15 @@ license=('custom')
depends=('glibc' 'alsa-lib')
provides=('flite' 'flite-fpic')
replaces=('flite')
-source=(http://www.festvox.org/flite/packed/${_pkgname}-${pkgver}/${_pkgname}-${pkgver}-release.tar.bz2)
-md5sums=('b7c3523b3bbc6f29ce61e6650cd9a428')
+source=(http://www.festvox.org/flite/packed/${_pkgname}-${pkgver}/${_pkgname}-${pkgver}-release.tar.bz2
+ ${pkgname}.patch)
+md5sums=('b7c3523b3bbc6f29ce61e6650cd9a428'
+ 'd818853cb4e416b76457ed63df7fde9c')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}-release"
+ patch -p1 -i ../${pkgname}.patch
+}
build() {
cd "${srcdir}/${_pkgname}-${pkgver}-release"
diff --git a/flite-fpic.patch b/flite-fpic.patch
new file mode 100644
index 000000000000..cad7b6969166
--- /dev/null
+++ b/flite-fpic.patch
@@ -0,0 +1,16 @@
+--- flite-1.4-release/config/common_make_rules 2016-02-11 00:03:18.569835816 +0100
++++ common_make_rules 2016-02-11 00:04:03.459592627 +0100
+@@ -108,11 +108,11 @@
+ $(CC) $(SHFLAGS) $(DEFS) $(CPPFLAGS) $(CFLAGS) -c $< -o $@
+
+ $(OBJDIR)/.build_lib: $(FULLOBJS)
+- @ (cd $(OBJDIR) && $(AR) cruv ../../../$(LIBDIR)/lib$(LIBNAME).a $(OBJS))
++ @ (cd $(OBJDIR) && $(AR) crv ../../../$(LIBDIR)/lib$(LIBNAME).a $(OBJS))
+ @ $(RANLIB) $(LIBDIR)/lib$(LIBNAME).a
+ @ touch $(OBJDIR)/.build_lib
+
+ $(OBJDIR)/.build_so: $(FULLSHOBJS)
+- @ (cd $(OBJDIR) && $(AR) cruv ../../../$(LIBDIR)/lib$(LIBNAME).shared.a $(SOOBJS))
++ @ (cd $(OBJDIR) && $(AR) crv ../../../$(LIBDIR)/lib$(LIBNAME).shared.a $(SOOBJS))
+ @ $(RANLIB) $(LIBDIR)/lib$(LIBNAME).shared.a
+ @ touch $(OBJDIR)/.build_so